
(圖 3.3) 主視窗包含功能表、工具列和指令列 

3.1.1  功能表 

功能表位於圖 3.3顯示主選單的上方，每一個選單均有下拉式選項，若選項不支援則會以灰
色顯示。

♦ 檔案 (File) - 開啟、儲存檔案。以及載入、輸出 Code V、Oslo、Zemax、Atmos、Modas
等軟體的透鏡設計檔。此外，還有偏好設定、歷史紀錄檔的快速存取也在檔案選單之中。

♦ 選項 (List) - 各種清單式輸出選項，例如透鏡配置 (lens prescription)、鍍膜 (coatings)、鏡
片材料 (glasses)、優化資料 (optimization data) 等。

♦ 編輯 (Edit) - 提供編輯、插入、刪除或逆轉透鏡表面、變焦資料、Zernike表面資料等選單。 
♦ 顯示 (Display) - 顯示透鏡設計圖及座標軸。
♦ 幾何分析 (Geom.Analysis) - 以幾何式的特性分析，例如光點圖 (spot)、橫向像差光扇圖

(transverse ray aberrations, Fan)、散光(astigmatism)、畸變分析 (distortion) 等等。
♦ 繞射分析 (Diffr.Analysis) - 以繞射做為為基礎的計算分析，例如 MTF、PSF、波前像差

(wavefront aberration)、干涉分析 (interferogram) 等等。
♦ 工具 (Tool) - 進階或特殊功能，包含自動聚焦 (autofocus)、透鏡規範轉換、簡易光學 (含
望遠鏡) 系統解析解、使用者自訂圖、巨集等等。

♦ 優化 (optimization) - 設定與執行優化功能。
♦ 鏡片屬性管理器 (Glass Manager) - 觀看內建鏡片材料的光學屬性，例如古典 n-ν圖、局
部色散圖 (partial dispersion diagrams)、漸變式輪廓 (gradium profile) 等等。

♦ 鍍膜 (Coatings) - 提供編輯和優化包含反射、相位和透射等鍍膜屬性。
♦ 製造 (Manufacturing) - 支援包含樣板測試擬合 (test-plate fitting)、非球狀圖 (aspherization

plot) 等等。
♦ 說明 (Help) - 啟動線上說明系統。

3.1.2  鍵盤熱鍵 

一般除了使用滑鼠來開啟各項選單外，使用者也可以使用鍵盤的熱鍵來開啟常用的選單。

舉例來說，鍵入”Ctrl+S”可立即儲存光學設計檔。 
需注意，假如是在指令列、對話框中或選定某分頁視窗中，則熱鍵功能將不會作用。
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3.1.3  工具列 

工具列提供了快速執行常使用到的一些功能，當把滑鼠移動到某一個圖示上，則立即顯示

關於該圖示簡要的功能提示。

產生一個新系統，覆蓋先前系統的資料

從既有檔案開啟一個系統

儲存系統資料到一個檔案

編輯表面資料，如孔徑、像場、波長

啟動透鏡表面編輯器

列出光學系統的透鏡配置

  顯示透鏡設計圖（Y/Z平面） 

  光學系統三維描繪的光影追蹤 (POV-Ray) 界面 

顯示通過切向和縱向瞳的光線像差

產生光點圖

  計算繞射點擴散函數 (diffraction point spread function) 

計算繞射點擴散函數所得到的灰階圖

  計算繞射光調變轉換函數 (MTF)vs像場，若只有一個像場點，則以 vs頻率來取代 

編輯優化變數與限制式

優化計算
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自動聚焦，從選定的像場與波長找出最佳聚焦

  編輯變焦/多表面配置資料 

編輯公差

編輯（物理光學）光束傳播參數

產生透鏡圖之光線

根據系統定義，計算最大所需表面高度

編輯薄模結構參數

計算反射屬性

計算透射屬性

啟動線上說明系統

3.1.4  指令列 

除了功能表的使用以外，OpTaliX也能夠單在指令列上來執行，提供的兩個指令列中，一個
位在工具列下方，另一個位在文字視窗下方，如圖 3.4和圖 3.5所示。這兩個在功能上是完全一
樣的。各指令和詳細的語法都描述於參考手冊和線上說明系統。結合使用歷史記錄視窗和功能

表，可以方便的學習這些指令，因為大部分的功能表使用歷程都會自動記錄在歷史紀錄視窗中。 
正常來說是不需要將滑鼠游標移至指令列上來輸入指令，因為軟體會自動偵測鍵盤輸入的

有效字元，並自動反應在文字視窗的指令列上。

輸入和改變資料是以自由格式指令語法來實現，此與 CODE-V有點類似。所有指令的參數
必須至少以一個空白來隔開，大部分的指令都可以接受疑問提示 (?)。 
指令的參數可包含數值表示式，像是 THI s3 sqrt(2)+1。幾個指令可以給定在同一列上，但

須以分號 (;) 來隔開，而每一個指令列可容納 256個字元。 
大部分的指令接受如表面、像場、波長、變焦位置、光線、係數、瞳等等參數。可被認可

的參數如下表：
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舉例來說，s3..4 表示透境表面 3到 4，假如指令的輸入中沒有任何引數，預設值將會被使
用上，一些指令有使用到配置對話視窗 (configuration) 的設定，例如光點圖會使用到定義在配
置檔內的像場與波長的值。

在下列的例子中，概要簡介一些指令的語法，當然需要更完整的說明或範例，還是需要參

考手冊，"！"右方代表對各項指令的說明，乃不屬於指令的一部份。 

rdy s1 3 10.0  ! 設定 1到 3表面的半徑為 10.0
 yan f4 2.5    ! 設定像場 2到 4的角度為 2.5度

psf f1 ! 計算像場 1的繞射點擴散函數

(圖 3.4) 文字視窗底下的指令列 

(圖 3.5) 功能表與工具列底下的指令列 

3.1.5  狀態列 

狀態列是位在主視窗的底部，從左至右所包含的資訊如下：
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Grid 光線格點用來對圖形表現效能的評量，光線是以穿過入口瞳的 N乘 N格點來
定義。N值越高代表計算會越準確，然而計算的時間也相對較長，光線格點是
定義在配置檔（指令：EDI CNF；從功能表為 Edit>Configuration） 

OUT 指出文字和數據結果的輸出

GRA 指出圖形的輸出

POS 顯示目前選擇的變焦/多表面配置位置 
Path 展示目前該光學系統檔案的路徑和檔名

第２節  圖形視窗

對於各類的圖形，其圖形視窗都可以任意調整大小與位置。

(圖 3.6) 圖形視窗 

3.2.1  工具列 

工具列與其圖形視窗息息相關，允許使用者執行一些選擇性的動作，像是列印、改變繪圖

參數、縮放、全視窗、輸出圖形檔或更新圖形視窗等。每一個圖示的具體意義如下：

修改繪圖參數，例如繪圖比例、像差比例等等。對於每一種圖形視窗，使用此功能都會

開啟另一個的對話視窗

列印圖形，也適用於網路印表機
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全視窗繪圖

  圖形更新。例如透鏡設計資料已改變，也可參考 3.2.3章節的說明 

透過圖形視窗，也可以輸出圖形至其他檔案格式，提供者如下圖示所示：

  複製圖形至剪貼簿上，詳細參考 3.3章節 

  輸出圖形為視窗中繼檔 (Windows Metafile Format) 

  輸出圖形為電腦圖形中繼檔 (Computer Graphics Metafile format) 

  輸出圖形為可攜式網路圖形檔 (Portable Network Graphics format) 

  輸出圖形為可變向量繪圖檔檔 (Scalable Vector Graphics format) 

  輸出圖形為 PCX檔 (Paintbrush format) 

  輸出圖形為 BMP檔 (Windows bitmap format) 

  輸出圖形為 HPGL檔 (Hewlett Packard Graphics Language format) 

  輸出圖形為 AutoCAD圖檔 (Drawing Exchange Format) 

  輸出圖形為壓縮 PSF檔 (Encapsulated PostScript format) 

3.2.2  放大 

整個圖形區域的比例可以藉由滑鼠左鍵選取拖曳的矩形框而放大，如圖 3.7。 

mailto:pitotech@mail.pitotech.com.tw
http://www.pitotech.com.tw
http://www.pdffactory.com
http://www.pdffactory.com


(圖 3.7) 放大紅色區域 

3.2.3  圖形更新 

圖形視窗可依需要而自動更新，正常來說是不需要使用者手動更新。然而，繪製如有高計

算量的圖形（像是MTF、PSF），則必須要使用者需要而更新，否則程式反應將會變慢。 

更新圖形的動作是透過圖形視窗左方工具列的更新鈕 來完成，或者在圖形視窗雙擊滑

鼠鍵來完成。

第３節  剪貼板的支援

視窗剪貼板支援文字與圖形形式，不論在文字輸出視窗或歷史紀錄視窗的文字都可以選取

後而複製。使用的動作為點選欲複製區的左上角，握住滑鼠左鍵並拖曳至欲複製區的右下角，

釋放左鍵後按住鍵盤 Ctrl+C，將文字或圖形暫存於剪貼板中。 
圖形也能以開啟圖形視窗的剪貼板來複製，方法是選擇功能表 Options>Copy to Clipboard，

或點選圖示 來實現。

第４節  透鏡表面編輯器

透鏡表面編輯器是用來編輯透鏡表面參數的表格式對話視窗。從功能表 Edit>Surface Data，

或工具列圖示 ，或在指令列輸入 EDI SUR 來開啟。如下，分別將表面參數的各重要欄位

加以說明：
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標準資料 (Standard Data) 此表單包含大部分會使用到的資料，像是曲率半徑、厚度、透

鏡材料、圓形孔徑、表面類型等等

離心，傾斜 (Decenter,Tilts) 包含設定鏡片離心、傾斜表面的參數，特殊的傾斜模式也可以

在這裡定義

非球面 (Asphere) 包含旋轉對稱非球面和環形表面的變形係數

梯度折射率 (GRIN) 提供對梯度折射率模型的定義，也包含隨折射率變化的離心、

傾斜資料

求解 (Solves) 提供對近軸參數的直接控制，像是入射角、近軸光線角、光線

高、等光程條件 (aplanatic) 的基本運算 
特殊孔徑 (Special Aperture) 特殊孔徑包含所有非圓形的孔徑。定義矩形、橢圓形和多邊形

孔徑外型，也允許局部混合外型

全像圖(Hologram) 定義全像和光柵係數

雜項 (Misc) 雜項表面資料

(圖 3.8) 表面編輯器 

透過滑鼠或鍵盤在表格單中導覽，滑鼠導覽是非常簡單：

♦ 點選一個視窗分頁
♦ 點選一個行或列標題，來選擇所有的行或列
♦ 可使用捲軸來移動任意表單的各行列
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注意，表面編輯器對話視窗會佔用到到程式的大部分資源使用，假如幾個其他的應用程式

同時執行，對於Windows 95/98/Me 這些操作系統，可能會導致此程式的執行問題，因此建議關
掉其他的應用程式，當然在Windows NT/2000/XP並不會影響到這方面的問題，這只關乎於可用
的記憶體限制。

下面的章節，將對每一個分頁表單和欄位再加以詳述。

3.4.1  標準資料

標準資料 (Standard Data) 分頁包含常用到的透鏡基本資料，像是曲率半徑、厚度、透鏡材
料、孔徑等等，另外，對於較窄欄位（以"."點來表示）位於曲率半徑、厚度、材料等欄位的右
邊。允許此表面可因需要而調整參數，如表面半徑、厚度、材料變數的優化或，表示特殊項目

的解。可接受於欄位的代號功能有：

v 優化被指定的項目（單一位置變數）

z 優化被指定項目的變焦變數

integer number 表示對一個領前表面 (preceding surface) 的挑選。一個具負號的表面數代表有
相對的曲率或厚度距離

s 表示一個解

欄位標題有下列的意義：

類型

(Type) 
表明表面的類型。這是一個至多到四位元的字串，有些是必須要填的，而有些是可

選填的，可參考下表。舉例來說，SDM定義一個圓形表面，其離心或傾斜，並為
一個面鏡。

必要的表面類型 可選擇的表面類型

S 圓形表面 D 離心和（或）傾斜的表面
A 非球狀表面 M 平面鏡
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L 透鏡模組（理想透鏡） G 光閘 (Grating) 表面 
X 非光線覓跡，只轉換表面座標而沒有
實際覓跡光線到該表面

H 全像表面

U 使用者自訂表面 F 超薄型表面 (Fresnel) 
I 漸變折射率
N 非序列式表面，必須與"D"組合使用 
P 光導管、步階型光纖
R 一致表面單元陣列
T 內部全反射 (TIR) 表面 
Z Zernike表面 
C 旋轉對稱曲線面變形
W 二維表面變形
E 純二維曲線非對稱（無基準面）

半徑

(Radius) 
曲率半徑。若曲率中心位在表面右邊則為正，反之則負。這個規則與光的方向無關 

距離

(Distance) 
沿光軸的兩個連續表面的間隔。假如下一個表面位在目前表面的右邊則為正，反之

則反。順著一個平面鏡的距離也是負的

透鏡材料

(Glass) 
內建光學材料庫的名稱（玻璃、塑膠、液體等等）

APE-Y 半孔徑 (Semi-aperture) 半徑  

* 本欄位表示：假如一個表面孔徑有被檢查，只有 0（未檢查）或 1（已檢查）可被
接受。前者，代表表面孔徑外的光線是被遮蓋。注意，孔徑光欄表面 (stop surface) 
總會是一個被檢查的表面

孔徑外型

(Shape) 
孔徑外型既可為圓形（預設）、橢圓形、矩形或多邊形

Glb 全域參考座標 (Global Referencing)，參考一表面至目前表面法線和領前表面的端點 

備註

(Comment) 
對表面的註解

鍍膜

(Coating) 
指定一個鍍膜檔案（最多八個字元）的，附加至一個多層鍍膜於一表面上
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3.4.2  離心，傾斜 

所有需要定義離心和（或）傾斜表面的參數均可從本分頁視窗來輸入。額外的欄位（以"."
來表示）位於 XDE、YDE、ZDE、ADE、BDE、CDE等欄位的右邊，".”欄位允許的輸入項目有： 

v 優化被指定的項目（單一位置變數）

z 優化被指定項目的變焦變數

THR 參考厚度。此為參考至一領前表面的表面軸間隔（厚度）。不像法線厚度，一參考厚度
總在表面之前定義

TLM 傾斜模式。定義隨後表面的座標系統，計有：

♦ DAR - 離心和回復。在一表面傾斜/離心後，座標系統回復為光學軸，如此，光學
軸不被改變

♦ NAX - 新軸。如名，目前表面法線定義所有隨後表面的新軸
♦ BEN - 彎曲表面。光學軸依循反射定律，只能在與平面鏡結合時才使用

SEQ 傾斜順序。此描述傾斜/離心的順序，字母 X、Y和 Z表示離心，字母 A、B和 C分別
表示對 X軸、Y軸和 Z軸來傾斜。因此，字串 XYZABC表示表面依序在 X離心、Y
離心、Z離心、對 X軸旋轉、對 Y軸旋轉、對 Z軸旋轉的座標轉換 

Pik 表示對領前表面的挑選為傾斜

XDE X離心 

YDE Y離心 

ZDE Z離心 
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ADE 對 X軸的傾斜角（α傾斜） 

BDE 對 Y軸的傾斜角（β傾斜） 

CDE 對 Z軸的傾斜角（γ傾斜） 

3.4.3  非球面 

非球面表面的參數是位於第三個分頁選單上。非球面是以多項式函數來描述，其對局部 Z
軸旋轉。該定義包含圓錐形表面（拋物面、橢圓面、雙曲面）和環面。額外的欄位（以"."來表
示）位於 A、B、C、D、E、F、G、H等欄位的右邊，".”欄位可接受的輸入項目有： 

v 優化被指定的項目（單一位置變數）

z 優化被指定項目的變焦變數

Asph.Type 選擇較高階係數的定義。可翻閱參考手冊關於"odd"和"even"多項式係數的的
詳述

K 圓錐常數 K描述圓錐區段的表面： 

♦ -1 < K < -1 雙曲面
♦ -1 < K = -1 拋物面
♦ -1 < K < 0  橢圓長軸
♦ -1 < K > 0  橢圓短軸
♦ -1 < K = 0  圓

A,B,C,D,R,F,G,H 高階多項式係數

RDX X/Z平面的半徑。假如該向非零，則表面為環形（在 X和 Y方向有不同的曲
率）

mailto:pitotech@mail.pitotech.com.tw
http://www.pitotech.com.tw
http://www.pdffactory.com
http://www.pdffactory.com


95

3.4.4  梯度折射率 

梯度折射率 (GRIN) 屬性。雖然基本上是描述著材料屬性，但這些資料仍可設定在表面上。 

GRIN-Type 梯度折射率類型 (GRIN-Type) 描述折射率輪廓所構成的方程式，有下列的屬性可
用：

♦ URN - 羅撤斯特大學梯度。軸向與徑向混合的梯度
♦ SEL - 從 NSG公司發展的 SelfocTM梯度

♦ LPT - 從 LightPath發展的 GradiumTM梯度軸向輪廓

♦ AXG - 軸向梯度
♦ LUN - Luneberg梯度
♦ SPG - 球面梯度
♦ MAX - 馬可仕威爾魚眼
♦ GLX - GLC開發的軸向梯度

Step 光線覓跡過程中，沿著光學路徑對步階長做積分。步階越小，結果將越準確，然

而，也會越耗電腦資源

Z-Offset 定義表面端點 wrt. 輪廓的位置。只有軸向梯度 (LPT) 才需要用到 

GXDE 梯度折射率輪廓 wrt. 目前表面端點的 X離心 

GYDE 梯度折射率輪廓 wrt. 目前表面端點的 Y離心 

GZDE 梯度折射率輪廓 wrt. 目前表面端點的 Z離心 

GADE 梯度折射率輪廓對目前表面 X軸的傾斜 
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GBDE 梯度折射率輪廓對目前表面 Y軸的傾斜 

GCDE 梯度折射率輪廓對目前表面 Z軸的傾斜 

Coeff. 開啟對話框來編輯使用者自訂的 GRIN係數。本選項只當表面為 GRIN、透鏡材
質為"GRIN"、梯度折射率輪廓類型 (GIT) 為 URN、LPT或 UDG時才能選用 

MXG 最大疊代數。當最大設定數達到，將終止孔徑光欄光線的疊代。輸入"MXG 0"來
關閉限制查核。注意 MXG 0 將不會設定疊代數至無窮大，而將孔徑光欄光線內
部疊代在 5000步階之後，以避免無窮迴圈。因此，假如需要超過 5000次疊代，
則必須隱式設定，舉例來說，MXG 20000 

3.4.5  求解

定義求解參數。求解允許對近軸屬性的直接控制，舉例來說，指定求解的條件中，可以保

持某近軸光線角度，保持近軸光線高度、或某一近軸光線入射角為一特定值。求解就是要滿足

所給定的這些需求。

Solve-type 求解類型 (solve-type) 定義哪一種近軸需求被滿足。可用的類型是光線角、
光線高度、入射角、等光程 (aplantic)和邊厚度。有兩種求解類型可以被套用
在一表面上

Param.1 第一參數，其依據求解類型。欄位標題將隨被選擇的求解類型來更新，以輔

助使用者能夠輸入正確的數值

Param.2 第二參數，只在邊厚度計算時才需要使用。其指定某邊厚度所需維持的軸高 
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3.4.6  特殊孔徑 

特殊孔徑是指所有非圓形的孔徑，可定義表面上至多十個基本孔徑外型（矩形、橢圓形、

圓形和多邊形），這些基本孔徑外型可以透過邏輯運算因子 OR和 AND來混合。 
每一個孔徑元素都可以被穿透或阻礙，每一個孔徑也可以從該表面端點做 X和 Y方向的離

心，並可旋轉。

(圖 3.9) 編輯特殊孔徑。一個分離的視窗可用來定義多邊形孔徑的各端點 

如圖 3.9所示，在特殊孔徑對話視窗中，從下拉式選單中選擇表面至視窗做左邊，對於此透
鏡表面的該孔徑資料將立即同步更新，至少需要一個基本孔徑，通常圓形是最常用的基本孔徑。 
基本孔徑必須建構來包含於光線覓跡過程中。檢查在"On"欄位中的核取方塊，如果表面上

有超過一個基本孔徑，則孔徑資料必須連續地輸入在表面中。

編輯多邊形孔徑，首先在"外型 (Shape)"欄位中選擇"多邊形 (polygon)"，在視窗最右邊欄位
的"多邊形 (polygon)"按鈕則可以點選，點選後就可進入多邊形孔徑編輯視窗。 
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3.4.7  繞射元件 

通常，繞射元件表面 (Hologram) 也可表示為繞射表面 (diffractive surfaces)，一繞射表面的
光學屬性是依據在一光線交叉點可被看見的有效光柵間距上的繞射。OpTtaliX在處理一光柵是
以一繞射表面的特殊案例。

(圖 3.10) 編輯全像係數 

繞射表面具高度分散性，OpTaliX提供幾種繞射（全像）表面： 

♦ 線性光柵 (Linear grating)
♦ 可變線性間距光柵 (VLS)
♦ 光學全像，由雙光束干涉所形成
♦ 電腦產生的繞射表面 (CGH)，以使用者指定軸向對稱相位分佈
♦ 電腦產生的繞射表面 (CGH)，以使用者指定非對稱二維相位分佈
♦ 使用非常高折射率的"Sweatt"模型

繞射類型可在對話視窗的右半區來選定，每一個繞射表面需要設計波長和繞射階數的指定。 
需注意繞射繞射係數描述著波前的相位改變，一階微分是在繞射元件表面上的光柵常數，對於

線性光柵，一階微分是一個常數，因此，在特殊案例中，光柵常數是與繞射係數相一致，這使
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得定義光柵變得更容易些。

第５節  新光學系統的建立

我們的第一個和相對簡單的案例是消色差雙透鏡 (Achromatic Doublet)，這需要透鏡表面資
料的輸入，也就是透鏡設計資料。典型的設計資料除了透鏡外，還有孔徑、視景和波長。本案

例之雙透鏡將有 200mm的焦距長，30mm的直徑，和 ±1度的視景，而物體 (object) 假設為無
窮長。

(圖 3.11) 消色差雙透鏡 

本案例將提供兩種形式來達成模擬，第一個是使用視窗功能表，接著是單純使用指令列。

3.5.1  由功能表輸入 

1. 我們現在將建立一個新的透鏡，因此，需刪去先前系統的所有設計資料，我們可以從功能

表 File>New或點選工具箱圖示 來達成這個目的。

2. 輸入透鏡表面資料。選擇功能表 Edit>Surface Data或點選工具箱圖示 來開啟表面編輯

器，開啟後表單包含三行，相當於物體光源標籤 OBJ、孔徑光欄表面標籤 STO和成像表面
標籤 IMG。

3. 對於雙透鏡系統，必須要有六個表面，其中四個為折射表面，另兩個為物體光源和成像表

面。在本案例中，我們選擇第一個光學表面做為孔徑光欄表面，因此還有三個表面必須加

入到系統中，我們移動游標至第三行（標籤為 IMG），並點選表單下方的"Insert Surf"共三
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次來插入三個表面。

4. 對於最基本的輸入參數，曲率半徑、軸向間隔距離和透鏡材料必須輸入，目前我們保留表

面孔徑在 APE-Y的欄位為零，因為這將會在稍後自動計算，因此表面編輯表單現在看起來
如下圖所示：

5. 我們也希望調整定義在表面 4最後距離的焦距面位置，這個距離總是以最後表面至成像表
面的間隔距離，這也可以依據近軸影像 (paraxial image, PIM) 來自動的調整，可自行參考
圖 3.8的下半區說明，假如 PIM被勾選，則成像表面會自動移動至近軸影像的位置上。因
此，最後距離也將改變於表面參數的修改上（半徑、距離、透鏡材料等），假如 PIM沒被
勾選，成像表面至最後表面的間隔將會被自動更新，因此，表面編輯器上的最後距離將不

會改變，使用者可自行衡量放置影像位置至適當的位置上。

6. 我們將在透鏡設計對話窗中定義操作環境條件。開啟功能表 Edit>Configuration data，或點

選工具箱圖示 ，此視窗包含幾個分頁標籤。

7. "孔徑 (Aperture)" 分頁視窗提供幾個定義孔徑的方法，我們點選"入口孔徑(Entrance
aperture, EPD)"選擇鈕，並在數值欄位上輸入想要的數值 30.0mm，注意，孔徑光欄表面是
在第四個表面上，不是我們想要的位置上，雖然這不怎麼影響影像屬性，因為雙透鏡只使

用在靠近光軸處，但我們也可以適當地設定孔徑光欄表面，在這裡，我們設定孔徑光欄表

面為 1，所以其他的設定保持不變。
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8. 在"Field"分頁視窗中指定視場，我們分配最大視景±1度為三個視角 0、0.5和 1度。注意，
輸入的值總是以從 X和 Y上的光軸量測的半視角。我們輸入視角(3)的這些值在"Field Y"欄
位的視角，因為物體是在無窮遠處，只有視角資料是以物體角的定義才有意義，這保留為

預設，無須進一步的改變。
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9. 在"Wavelengths"分頁視窗上定義波長 546nm，請注意所有在 OpTaliX定義的波長都是以
microns來指定，因此 546nm的波長需輸入為 0.546。我們還將加入另兩個波長，450nm和
650nm，使其有三個近似於可見光譜範圍內的波長，其波長數值必須增加於於清單上，參
考波長是當近軸特性被計算時的波長，權重介於 0至 100的整數，用以模擬一相對光譜分
佈，且權重的絕對值是不重要的，對所有波長輸入 1的結果是導致一均勻平坦的光譜分佈。 
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10. 所有必須輸入的操作參數已經定義完成，我們將關閉透鏡設計對話視窗。對於光學系統的
輸入，我們可以列印透鏡描述來檢查是否近軸資料是如預期。選擇功能表 List>Surfaces，

或點選工具箱圖示 ，輸入的結果如下：

11. 如預期，焦距長 (EFL) 為 200mm，剩下還需定義的參數是表面 2-5的表面孔徑，我們現在
可讓系統自行計算這些值，選項MHT將決定最大需要表面高度，請開啟功能表 Tools>Set
maximum，或點選工具箱圖示來完成。

12. 最後一步，我們將繪製透鏡設計圖，請開啟功能表 Display>Lens Draw Y，結果應會如圖 3.11
所示。

3.5.2  由指令列輸入 

本章節重複先前案例，但將使用指令列的方式來進行，驚嘆號"!"後面的文字僅為註解，不
屬於指令的一部份。

Len ! 建立一新系統，所有之前的資料將被刪除
ins s1..4 ! 在最後一個表面前插入四個表面
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我們現在將輸入透鏡表面資料，例如曲率半徑、厚度和透鏡材料

rdy s1 119.1653 ! 設定表面 1的曲率半徑
thi s1 5 ! 表面 1之後的厚度
gla s1 bk7 ! 表面 1透鏡材料是 Schott BK7

對表面 2-4重複資料的輸入 
rdy s2 -137.1862 
thi s2 1.5 
gla s2 ! 在表面 2後的介質為空氣，因為新系統採用了預設值，此指令可以忽略
rdy s3 -121.7583 
thi s3 3 
gla s3 sf6 
rdy s4 -230.8567 

我們現在定義系統孔徑、視景和波長

epd 30 ! 設定入口孔徑半徑
yan 0 0.5 1 ! 定義三個視角為 0、0.5和 1度
wl 0.546 0.45 0.65 ! 定義三個波長
ref 1 ! 參考波長為 1
set mht ! 根據指定的孔徑與視點，設定最大所需表面高度
透鏡設計圖現在將被繪出

vie ! 繪製一光學系統在 Y/Z平面的剖面視圖
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第４章 案例介紹

第１節  傾斜表面案例

在本案例中，我們要學習如何設計傾斜和離心透鏡表面，我們使用現有雙高斯設計範例

(Double-Gauss) ，此案例存在於目錄 example\misc\double_gauss.otx。我們將插入一 45度旋轉面
鏡 (fold mirror) 於最末透鏡表面和成像表面之間，下面的圖檔顯示預計的結果。 

(圖 4.1) 具旋轉面鏡的雙高斯設計 

4.1.1  由功能表輸入 

開啟功能表 File>Open，瀏覽資料夾的 misc子目錄，點選並開啟檔案 double_gauss.tox。接

著，選擇功能表 Edit>Surface data或直接點選工具列圖示 。

此光學系統由 12個包含物件表面和成像表面所組成，在最末（折射）表面之後將插入額外
的旋轉面鏡表面。所謂插入表面是指實際表面之前，那就是說在我們的案例中，插入一成像表

面之前，因此，在表面編輯器中，我們將移動游標至成像表面欄位上，即表單中的最後一表面

12，此表面也以"IMG"來標著，接著點選"Insert Surf"鈕來插入表面，也就是我們稍後將修改的
表面。

現在，此光學系統將有 13個表面，表面 12的一些屬性必須改變使其變為一傾斜面鏡。首
先，此表面的表面類型需要修改，在"TYPE"欄位上顯示為"S"，表示為一球面，這肯定是正確的，
因為面鏡是為平面 (plano，曲率半徑無窮大)，然而，我們必須在此表面上指定反射與傾斜/離心
屬性，因此需修改表面類型為"SDM"，其額外的字元"D"和"M"描述為： 
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♦ D: 傾斜/離心
♦ M: 面鏡

我們現在要設定傾斜和面鏡表面位置參數。在透鏡表面編輯器中，選擇 "Decenter,Tilts"分
頁標籤，接著改變表面 12的"TLM"傾斜模式欄位從"DAR"變為"BEN"。 
傾斜模式敘述表面的傾斜和（或）離心如何被處理，由"BEN"模式根據反射定律，在面鏡

表面的光軸偏斜，因此這不需要去改變所有隨後表面的位置（本案例中，即為成像表面），因為

這已經在折彎模式 (BEN) 完成了。 
最後，我們對表面 12的"ADE"欄位上，輸入傾斜角，"ADE"是對 X軸的傾斜，其單位是角

度，其正負號代表如下：

♦ 正號：傾斜是逆時針方向
♦ 負號：傾斜是順時針方向

-45度角將表示傾斜表面順時針方向，並在面鏡反射後折彎光束向上。最後一步，我們改變
在"Standard data"分頁視窗中，改變表面 11的軸距為 10mm，這是為了讓旋轉面鏡位於最後透鏡
表面與成像表面的中間，產生的透鏡設計圖 (VIE指令) 將如圖 4.1所示。 

4.1.2  由指令列輸入

同上一章節的雙高斯設計案例，在最後一透鏡表面與成像表面間插入一旋轉面鏡：

ins s12 在表面 12（成像表面）之前插入一表面。而成像表面的代號增加為 13 
sut s12 SDM 表面 12的表面類型為球面 (S)、離心 (D)和面鏡 (M) 
ben s12 改變傾斜模式為 BENd（面鏡的光軸遵守反射定律） 
ade s12 –45 傾斜角（對 X軸）為 45度，注意正負號，正號為逆時針，負號為順時針 
thi s11 10 改變表面 11的軸向厚度為 10mm 
vie 顯示二維 Y/Z平面的設計圖 

第２節  非球面表面案例

本案例證明非球面表面如何用來改善透鏡的成像品質。做為開始設計初段，我們也是從資

料夾開啟一個現有的單一透鏡來著手，檔案存放位置為 examples\tutorial\BestformLens.otx ，顯
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示的結果如圖 4.2，此顯示出一明顯的球面像差，可透過像差光扇圖或光點圖來觀察（點選 

或 ；或是在指令列中輸入指令 'fan' 或 'spo'）。我們的目標是對第一表面引入非球面變形 

(aspheric deformation) 來減少球面像差，非球面表面需要的透鏡表面類型為取代預設透鏡表面類
型"S"的"A"，因為表面只能是球面 (S) 否則是非球面 (A)。 

(圖 4.2) 非球面化一透鏡 

4.2.1  由功能表輸入 

在表面透鏡編輯器中，我們在表面 1的透鏡表面類型的欄位上以"A"取代"S"，注意，表面 1
也是孔徑光欄表面，因此標籤名稱為'STO'。 
為了簡化，我們只使用二次曲線，有拋物線、橢圓、雙曲線。在透鏡表面編輯器中的"Aspheric"

分頁視窗中，二次曲線常數 K=-0.7106137必須輸入於表面 1（第二列）的"K"標籤欄位上，如
圖 4.3。 

(圖 4.3) 輸入二次曲線常數 

重複光點與光扇像差圖顯示出像差已經減少到幾乎看不出來了。點選圖形視窗圖示 來

改變像差的繪圖刻度，並輸入 0.001 (mm) 於隨後開啟的視窗，來觀看殘留像差 (residual 
aberration)。 
較高階的非球面項可以被導入以消去微小的球面像差。這些係數以字母字元 A到 F，分別

出現在相對應的欄位上，如圖 4.4所示，輸入前三個係數 A至 C： 
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