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Chapter 2
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Just Do It: Design a Digital

Camera Lens
动手做：设计一个数码相机镜头
In this chapter, you will design a fixed-focus digital camera lens for VGA res​olution (640 x 480). 在这章，你将会设计一个定焦数码相机镜头，它的显示绘图阵列分辨率是（640*480）。Guided by the required specifications, you will use the New Lens Wizard to identify a suitable starting point. 根据说明书的指导，你将会使用新镜头向导去定义一个适宜的起点。You will then modify, analyze, and optimize the optical system to meet the requirements. 然后你将修改、分析、优化你的光学系统使它满足你的要求。This will allow you to learn most of the basic techniques needed to use CODE V.这将使你学会使用CODE V的大部分基础技术。
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Learning by Doing
A Simple Digital Camera Lens 一个简单的数码相机镜头
Digital cameras are very common these days, and the latest mega-pixel models have high-resolution CCD arrays and sophisticated optics and electronics.数码相机在今天已相当普及了，最新的mega-pixel 有高分辨率的CCD阵列以及很成熟的光学和电子学。But don't worry, that won’t be your very first task with CODE V. 但这并不你学习CODE V的第一任务。Instead, you will design a fairly simple objective lens for a fixed-focus digital camera.你将为定焦数码相机设计一个相对简单的物镜。 This will still require some optical design, but it’s a relatively simple problem, a two- or three-element centered lens with glass and/or plastic refracting lens elements.这需要一些光学设计，但那只是相对简单的问题，一个两单元或三单元的由玻璃或塑料折射透镜单元组成的镜头。
Here is what you will learn in this chapter:以下将是你这章所要学习的：
· Interpret general design specifications for a simple lens给出你的镜头的大致设计说明
· Use this information to identify a starting point用这些信息来确定你的初模
· Modify the starting point to match the requirements修改你的设计初模使它符合你的要求
· Perform a basic analysis, compare these results with the specs, and determine guidelines for optimization执行基础分析，对比规格决定优化指导
In the next chapter, you will use the results of this chapter as a starting point to下一章你将根据这一章的初模结果优化你的镜头
· Optimize the lens优化镜头
· Identify problems with the design for potential refinement它和镜头细微改进设计的问题有关
These steps will allow you to work with many of CODE V's features through various phases of optical design. 在各个光学设计过程中将使你了解到CODE V里面的很多功能特点。We will explain some of these features as they are introduced here, with additional explanations in subsequent chapters.我们将在这章引入这些功能，并将在下一章作进一步解释。
Design Specifications 设计说明
Sometimes you will receive a lens prescription from someone and you will need to enter it in CODE V, analyze it, and perhaps optimize it. This is fairly straightforward. 有时你将收到一些透镜库并把它载入CODE V，这是相当简单的。In other cases, a design problem starts out with a spec, or set of specifications, on how the lens must perform, and from these guidelines you must determine a starting point, set it up, analyze, and optimize it.在其他情况下，一个设计从它的初模的开始，说明书将告诉你要怎样操作的，这些你将从这些指导中决定选取哪个初模。
For this digital camera problem, the spec came from a CODE V customer who makes consumer products. The question was, “If you wanted to define a low-cost, fixed-focus digital camera for VGA, how would you specify it?”对于一个数码相机，它的规格来自CODE V的顾客，那些生产消费产品的人，也就是说“如果你要一个低造价、定焦的数码相机，那么你需要如何选择初模和设计”
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[image: image49.png]Fixed-focus VGA Digital Camera Objective Specifications

· Small number of elements (1-3) made from common glasses or plastics由普通玻璃或塑料制成的低数量单元（1单元~3单元）Image sensor (baseline is Agilent FDCS-2020)
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640 x 480 effective pixels
7.4 x 7.4 microns

3.55 x 4.74 mm (full diagonal 6 mm)

Fixed, depth of field 750 mm (2.5 ft.) to infinity Fixed, 6.0 mm

<4%

Fixed aperture, f/3.5

MTF through focus range

(central area is inner 3 mm of CCD)

	Low freq., 17 lp/mm
	>90% (central)
	>85% (outer)

	High freq., 51 lp/mm
	>30% (central)
	>25% (outer)


Vignetting渐晕
Corner relative illumination > 60%中央相对强度>60%
Transmission透过率
Lens alone, > 80% 400-700 nm

IR filterIR滤波器
1 mm thick Schott IR638 or Hoya CM500 What Does It All Mean?

For one thing, this means that it will be a rather small lens system.首先，它意味着这是一个小型透镜系统。 The sensor size and the focal length of the lens are each only 6 mm (about a quarter of an inch). 接收器尺寸和透镜的焦距只有6mm。The sensor size and the effective focal length (EFL) will establish the field of view (FOV) for the lens according to the infinite-object-distance relationship, h = f tan è or

Image height = EFL * tan(semi-FOV)接收器尺寸和有效焦距确定了无限远物的视场大小FOV，他们的关系是h = f tan è 或Image height = EFL * tan(semi-FOV[image: image51.png][image: image52.png][image: image53.png]


)In this case, the image height is 3 mm (half of the detector diagonal), and the EFL is 6 mm, so you can solve this for the semi-FOV of 26.5° (this is useful since the patent database lenses are listed by f/number and semi-FOV).既然这样，像高是3mm（接收器对角线的一半），EFL是6mm，因此可得出半视场角（semi-FOV）是26.5°（这是有用的，既然专利资料库里透镜都是按f/number and semi-FOV列出的） Given that you want a small number of elements, this is all the information you need to find some starting points.考虑到想设计的是小单元，这就是你选取初模所需要的所有信息
CODE V has analysis features to allow evaluation of the other specs (distortion, MTF, relative illumination, transmission). CODE V的分析功能可以给出其他规格（畸变，调制器传递函数，相对强度，透过率）的评价We will introduce most of these features later, as they are needed, but consider the term sharpness for a moment. Sharpness is often defined by MTF, which quantifies the lens' ability to image information as a function of spatial frequency.在它们需要的时候我们稍后将介绍这些大部分的功能，但是考虑到锐度这项特性，它常常是由MTF确定的，MTF以空间频率函数的形式定量地描述了透镜成像信息的能力。 Maximum sharpness is given by an MTF of 1.0. Minimum sharpness (i.e., no information) occurs for an MTF of 0.0. High spatial frequencies represent small details and are measured in lines per millimeter. We will discuss MTF and other evaluation methods in more detail later.当MTF为1时锐度最大，当MTF为0时锐度最小，高空间频率对应着细节。我们等会将更细致地讨论MTF和其他评估方法。
A digital camera uses a CCD array consisting of small but finite-sized cells called pixels (there are actually three color pixels for each cell, but for design purposes, we will think of each cell as consisting of a single pixel).数码相机使用CCD阵列成像，它们是由许多小且有限大的像素组成（事实上每个像点都有三种颜色的像素，但出于设计目的，我们假定每个像点都只由一个像素组成）。 The spec indicates that the pixel size is 7.4 microns square. The maximum spatial frequency that this array will resolve can be calculated as one over twice the pixel size, 1/(2*0.0074) = 67.6 lines/ mm. 这些特性指出每个像素是7.4 microns 的方格，最大空间频率可以通过阵列的尺寸算出1/(2*0.0074) = 67.6 lines/ mm With this CCD array, any image information with a higher spatial frequency (i.e., finer detail) than this will not be seen. In spite of this, the optics must actually have non-zero MTF somewhat beyond the CCD cutoff frequency, so the combined optics/detector MTF will produce a usable contrast up to the CCD cutoff frequency. 高于这个空间频率的图像信息无法被CCD感知，尽管如此，光学设计实际上没有高于CCD截止频率的非零MTF，所以接收器MTF要综合考虑CCD的截止频率。This is the meaning of the small table on page 19 under the Sharpness specification.这就是19页表格里锐度的含义。
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[image: image56.png]The New Lens Wizard 新镜头向导
Starting a New Lens 开始设计一个新的镜头
The New Lens Wizard is a tool for creating new optical system models from existing designs (samples, patents, or your own saved favorite lenses) or from scratch.新镜头向导是一个基于已有设计（案例、专利、你已存的镜头）的光学系统设计模型制作工具。 It helps you to locate a suitable starting point and then define the essential system data corresponding to your specifications (including pupil size, wavelengths, and field data). Start CODE V and launch the New Lens Wizard now:它根据你的设计要求帮你确定你的初模和基本数据（包括光瞳尺寸、波长和场数据），打开CODE V并开始新镜头设计向导：
[image: image1.png]
1. Choose the File > New menu.选择File > New菜单
2. Click the Next button on the Welcome screen.点击Next
3. Click the button labeled Patent Lens and click the Next button. 点击Patent Lens
[image: image2.png]Where do you want to start from?
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In addition to some 30 sample lenses that demonstrate program features, CODE V includes a database of some 2,400 expired patents (mainly centered optical systems for various applications).除了演示软件特性的30个按列镜头外，CODE V还有2400个专利期满的基本数据（主要时各种光学系统的应用技术） You can use the New Lens Wizard or the Patent Lens Search feature (Tools > Patent Lens Search menu) to access and search this database through the use of filters that specify various properties. In the following procedure, you will continue using the New Lens Wizard to select a patent lens.你可以用专利镜头搜索功能Tools > Patent Lens Search筛选符合要求的基本数据，接下来选择一个专利镜头。
1. In the New Lens Wizard, click the Filter button.在向导中点击Filter
The Filter dialog box displays, which allows you to narrow down the search for a starting point. 在Filter 对话框中能缩小你的初模选择范围。In the case of the digital camera lens, you need both a relatively fast (small) f/number and a fairly wide field of view or field angle (26.5° semi-field angle, which corresponds to the 3 mm half-diagonal of the CCD array).就数码相机来说，你需要一个小的f/number和一个相对较宽的视场（26.5°半视场角对应3mm半对角线的CCD阵列）。 You also want this lens to be fairly cheap, so it should have a small number of elements (1-3). You can fill in the filter dialog to start the search. It's a good idea to expand the range slightly since you can often slightly modify or optimize a system to the needed specifications. 你还想要你的镜头比较便宜，所以你需要选择一个低单元（1~3单元），你可以填写入对话框来帮你寻找。稍微扩大一下你的选择范围是个不错的主意既然你等会还要修改和优化它使它满足你的要求。If you make the search targets too narrow, you may miss some promising design forms.如果你的搜索范围太窄的话你可能错过很多有希望的设计模型。
2. Click the check boxes and fill in the Min/Max entries for点击并填入一下信息的最小和最大值
· F/# (f/number, try 1 to 4), goal is 3.5

· Field of View (actually semi-field angle, try 20° to 33°), goal is 26.5°
· Number of elements (try 1 to 3), goal is smallest possible for low cost
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3. Click OK.

The New Lens Wizard returns you to the patent list where you will now find around 12 lenses that meet these requirements.向导将使你回到专利列表，现在有12组镜头满足你的要求。
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[image: image61.png]You could try several different starting points, but note that it will probably be hard to expand the field of view, so wider field starting points are better. 你可以尝试一下各种初模但你会发现很难扩大视场，所以选择一个宽视场的初模会更好一些。The lens named or02248 looks promising – it has a 27.5° FOV, and a faster (smaller) f/number than we need (2.4 -- this is good, since stopping down a lens to a larger f/number usually improves image quality).一个名为or02248看上去不错，它有27.5° FOV和a faster (smaller) f/number。
4. Click the lens named or02248 in the spreadsheet of patents.点击专利表格中的or02248
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5. Click the Next button to go to the Pupil page.点击Next
Defining the System Data 确定系统数据
Now you can complete the entry of the lens through the New Lens Wizard. The next few screens ask you questions about how the lens will be used, properties that CODE V calls system data.现在你已通过向导完成了进入镜头设计，接下来屏幕上的一些问题将问你这个镜头是用来做什么的、它的性质。 Note that the goal at this point is to get a working model that can be modified and optimized to meet the final specs. Further changes will be needed.注意到我们的目的是选一个我们能够修改和优化使之能够满足我们最终要求的初模，进一步的改变是需要的。
1. In the New Lens Wizard, you should be on the Pupil page. Choose Image F/ Number from the dropdown list, and enter the value 3.5.在向导中光瞳页面下拉列表中选择Image F/ Number并填入3.5
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F/number is a ratio, so it won’t need to be scaled when the lens is scaled (and the lens will most likely need to be scaled). F/number是个比值，所以在缩放时你不需要改变它
2. Click the Next button to go to the Wavelength page, and change the weight for the green wavelength (589.0) to 2.点击下一步进入波长页面，并改变绿光（589nm）的权重至2
This will give the central wavelength more emphasis later in optimization.这将在等会的优化中使中心波长更重要。
3. Click the Next button to go to the Reference wavelength page, but do not change the default value.点击下一步进入参考波长页面，但不要改变默认值。
This is the wavelength used for paraxial and reference-ray tracing; the default is OK.这种波长是用来近轴和参考光线追踪的，默认值就够了。
4. Click the Next button to go to the Fields page. Right-click on field 2 and choose Insert from the shortcut menu to add an additional field angle, then type the values 0, 11, 19, and 26.5 for the four field Y angles.点击下一步进入场页面，右击在场2并在快捷菜单中选择插入，并输入0，11，19，26.5在Y方向上。
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This lens is fairly wide-angle in field, so adding an additional intermediate field angle is a good idea for optimization and analysis.这个镜头有相对较大场角。所以增加一个中间的场角对于优化和分析来说是个不错的主意。 Typically, best practice is to have fields defined at 0, 0.7 and full field at a minimum. Adding intermediate fields can be helpful in controlling zonal variation of field dependent aberrations such as astigmatism.最好的行为是在0，0.7和满场情况下，添加一个中等的场角对控制由散光之类的像差的场的变化是有帮助的。
5. Click the Next button to go to the last page in the New Lens Wizard.点击下一步进入最后一页
6. Click the Done button点击完成.
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Working with Surfaces

The Lens Data Manager Spreadsheet镜头数据管理表格
The basic operation of CODE V is ray tracing – everything else is based to some extent on tracing one or many rays and doing some calculations with them. In the majority of systems, rays are traced sequentially through a series of optical surfaces you have defined. CODE V最基本的操作就是光线追踪，其他的工作也是在光线追踪和计算的基础上展开的。光线在你定义的光学面上被依次追踪，这就是系统的大部分。The properties of these surfaces will determine how the rays are traced. This is combined with system data to create a model of the optical system.这些光学面的性质将决定光线是怎样被追踪的，这些和系统的数据结合起来创建了一个光学系统的模型。
Since surfaces are the heart of any optical model, you will spend a lot of time looking at the Lens Data Manager (LDM) spreadsheet window, which is always present in the interface (you can resize or minimize it if you don't want to see it, but you can't close it).既然光学面是所有光学系统的核心，你将花很多时间用在镜头数据管理表窗口上，它总是在界面上（你可以把它最小化但不能关掉它）
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The LDM window behaves like spreadsheets in other programs in that you can re​size rows or columns, select cells or groups of cells, and enter data in cells. LDM就像其他程序一样可以调整行或列的大小，选定单元格或单元组并输入数据进去。Note that some cells are gray and do not accept data entry—these cells contain data calculated by the program and this can't be directly changed.注意到一些单元格是灰色的而且无法输入数据，它们是程序计算出来的数据且无法直接修改。 You can right-click on any cell, including gray cells, to see a menu for that cell. Right clicking is a very common operation which gives quick access to all available information for a cell.你可以右击任何一个单元格，包括灰色的单元格，并看到一个菜单。右击是一个常用的操作，它可以快速使用单元格的可用信息
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[image: image69.png]Tip: To see the full value of any displayed number, position the mouse pointer over the value and leave the pointer there (don't click). 为了查看显示数据值的全部，把鼠标放在数值上就可以了。To change the number of displayed digits for all numbers in the interface, choose the Tools > Customize menu and go to the Format Cell tab in the Customize dialog box (General format with 5 digits is used in this guide). You cannot format cells individually.要修改界面上数据值的显示位数，选择Tools > Customize进入Format Cell在Customize对话框中修改就可以了，但你不可以只单独改变某个数据的表达方式。
Note also that in the discussion below, we are considering the default display of the LDM window for rotationally symmetric optics. It is possible to hide columns (right click any header cell) or to make certain common entries blank同时注意到下面讨论的，对于旋转对称的光学系统来说我们可以考虑LDM的默认显示，我们可以隐藏竖栏或者把它们设成一个公共值 (e.g., Sphere and Refract; choose the Tools > Preferences > menu and go to the UI tab in the
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Preferences dialog box to change this). If there are non-rotationally symmetric surface properties, the LDM window will add additional columns for certain X and Y data.如果是个非旋转对称面，LDM将为X和Y数据添加一个竖栏
Surface Details

Every lens model will start with an object surface and end with an image surface (it is really just the last surface, since not every lens model will form an image there, though most will). 每个镜头模型都从物面开始在像面结束（它事实上是最后一个面，虽然不是每个镜头都会成一个像在像面上，但大部分是）You will also note that there is always a surface labeled Stop, which is the aperture stop surface. This is defined as the limiting surface for on-axis rays.注意到某个面上有个Stop标志，那是孔径光阑面，这是由轴上光线有限面所确定的。 The chief ray (or principal ray) from every field point will be iterated to pass through the center (x=0, y=0) of the stop surface, unless you override this behavior with chief ray aiming (this is only necessary in a few unusual situations).从各个场点发出的基线将重复经过孔径光阑的中心，除非你不理这种基线行为（它只对一些非常态情形是必要的）
Each row in the LDM spreadsheet has a surface number and a surface name (optional but very useful in complex systems). To select an entire surface (each is displayed in a row), click the surface number. The surface type is next, which is a dropdown list (double-click it to display a list of surface types), with the default type of Sphere.LDM每行都有一个surface number和一个surface name,这是可选的但在复杂的系统中通常很有用。曲面类型这个下拉列表（双击它会弹出一个曲面类型列表）它的预设曲面类型是球面。 The Y Radius is the radius of curvature, which is the reciprocal of curvature. Spheres and other rotationally symmetric surface shapes have only a single curvature, and Y is used for this (types such as Y Toroid have X and Y curvatures). Y Radius就是曲率半径，它是曲率的倒数。球面和其他旋转对称曲面只有一个曲率。 You can also choose to display the Y Curvature (reciprocal of radius, e.g., units of 1/mm). See the tip below.你还能显示Y曲率（半径的倒数），可以看下面的提示。
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[image: image75.png]Tip: You can work with radius of curvature or its reciprocal, curvature, by checking or un-checking the Edit > Radius Mode menu item.你可以校验Edit > Radius Mode菜单选项来选择是用曲率半径模式还是曲率模式。
Thickness is defined as the distance to the next surface, measured along the local Z axis of the current surface (which is the optical axis for centered systems such as this). Note that the thickness (air space) of surface 6 is gray and has a small S next to it. Thickness的定义是这个曲面到下个曲面的距离，它沿着Z轴测量的（它就是系统的光轴），注意到第六个面（空气）的厚度是灰色的，且有个S在它右上角。This thickness is set by a paraxial image (PIM) solve, which calculates the thickness at which the paraxial marginal ray has a height of zero at the following surface. 这个厚度是由近轴成像得出的，通过计算边界光线得出。This sets the paraxial image distance, where the lens is approximately in focus. This may not be the best focus, however, so the thickness of the image surface is used as a focal shift from the PIM value (the total image distance is the sum of these two values).这将设定一个近轴成像的距离，这个镜头近似在焦点处。但这不是最好的焦点，然而像面的厚度被用作从焦点到近轴成像位移的值（整个像距也就是近轴像距和像面厚度的和）。 Optimization usually determines the best focus shift (the combination of PIM solve and variable defocus is recommended for most optical systems).优化通常要确定最好焦点位移（近轴成像解和光学系统推荐的可变离焦的结合）
Glass cells contain the name of the material in the space following the surface, and if it is blank, the material is AIR. The glass determines the index of refraction, which is a fundamental requirement for ray tracing. 玻璃单元格包括曲面后填充空间的各种材料的名称，如果它是空的那么它将显示为空气。玻璃材料将决定折射率，它是光线追踪的基本所需。There are several possible forms for glass names, depending on whether they are from glass makers, defined locally for the lens (“private catalog”), or defined as “fictitious” glass whose index
can be varied to allow optimization, as shown in the example (there is a supplied macro, glassfit.seq, that can help you convert fictitious glasses into real glasses that you can buy).玻璃的名称有很多种，它们的信息是有玻璃制造商提供的，你可以用它作为个人列表来设计镜头，也可以通过设定参数自定义一个虚拟的玻璃来完成优化，但重要的是你能把虚拟的玻璃转换成你能够买到的真实的玻璃。 Refract mode determines the basic behavior of a surface, whether rays are refracted or reflected at the surface (double-click the cell to see the choices). Refract mode决定了曲面的基本行为，在曲面上是折射还是反射（双击可以看到选项）。
The final column is labeled Y Semi-Aperture and represents the size of the optically useful portion of the lens surface. By default, this is a centered, circular aperture calculated by the program to pass the reference rays from all field and zoom positions.最后一栏是Y Semi-Aperture，它表示的尺寸是镜头表面非常有用的一部分。在默认情况下，中心孔径尺寸是由程序算出所有场的参考光线而得出的。 You can change this to a user-defined aperture for any surface in several ways, the simplest of which is to right-click and choose one of the Change to… options that pops up. You can just accept default apertures for now, though later you will learn about the relationships between apertures, pupil size, and vignetting factors.有很多方法可以改成用户自定义状态，最简单的就是右击它选择Change to。此刻你可以选择默认值，尽管你已学过了孔径、光瞳和渐晕等因素之间的关系。
Changing and “Committing” Data

Changing data in the LDM spreadsheet is simple—click a non-gray cell and type a new value. You can also double-click a cell to display and edit the full value (or to display a list of choices in some cases). 改变LDM表格的数据是很简单的，你只需点击非灰色单元格然后输入新数据就可以了，或者双击它显示它的全部数值然后修改数据。If you change something by mistake, use the Edit > Undo menu to fix it (make sure that a spreadsheet or command window is in front; Undo will not be available if a graphics window or dialog box is in front). 如果你修改时修改错了可以用Edit > Undo来取消你之前的操作（但必须保证数据表或指令窗口是开着的，否则它将无法使用） Note that some cells have a small symbol or “glyph” next to the value, identifying a special state for that cell (e.g., S for solve, V for variable, Z for zoom).注意到有的单元格在它的数据后有个小标记，表示它有特殊状态。
To change the state of any cell (including a gray cell), right-click on it to see a shortcut menu of options (e.g., changing a solve to a variable will remove the solve and allow you to change the value directly, but be sure you want to do this since the solve may be there for a reason).要改变单元格（包括灰色的）的状态右击它会看到一个快捷菜单选项（比如说要把一个解值改为变量会清除清除它原来的值并允许你直接修改一个新的值，但你这种修改必须是合理的）
One of the right-click menu choices on any surface data item will be Surface Properties. This opens a large window that gives direct access to ALL properties of that surface, including many that do not appear in the LDM spreadsheet. We will cover Surface Properties a little later.每一个单元格右击菜单选项中都有个Surface Properties，这是一个大的窗口，在里面你可以看到曲面的所有性质，包括你在LDM列表中看不到的性质，我们等会再讨论这个。
You can also change data in the LDM spreadsheet by typing appropriate commands at the CODE V> prompt in the Command Window. This requires knowing the applicable command and its syntax (e.g., THI S5 2. 3 will change the thickness of surface 5 to 2.3).你也可以在指令窗口中快速地改变LDM列表中的数据，这需要你知道相关指令和语法。 When you enter a command this way and press the Enter key, you will also see the corresponding LDM spreadsheet or Surface Properties window update.当你输入一条指令并按下Enter键时，LDM和Surface Properties就会出现相应更新。
Don’t Fear Commitment

In CODE V, we use the term “commit changes” to refer to transferring the data from the place it is entered in the user interface (such as a spreadsheet cell or dialog box) to the lens database inside CODE V (sometimes called the “back end” of CODE V). Normally data is committed instantly—that is, as soon as you type or click in another cell, data field, or window. 在CODE V里面，我们采用“修改责任书”的形式来保存用户界面的数据，也就是说当你输入或点击到其他单元格时就保存你的修改数据了。This is similar to other programs such as Excel, except you will also see the corresponding commands displayed in the Command Window.这点和Excel等其他软件类似，所以你还需要在指令窗口中留意你的相关指令。
However, there are some cases in which a command is built from several data values entered in a row of a smaller spreadsheet (e.g., apertures in the Surface Properties window). In this case, the numbers are not committed until the row is completed.然而，有很多情况下指令是基于表格里的一行很多数据而生效的，在这种情况下只有该行所有数据都完成后指令才生效的。
The thing that may be confusing has to do with the different types of windows. Windows in CODE V come in two basic types, those that have OK and Cancel buttons (these are called dialog boxes), and those that do not (the main examples being the Surface Properties and System Data windows).当遇到不同窗口时是一件让人容易混淆的事。CODE V窗口有两种类型，一种是对话框，它们都有OK and Cancel按钮，另一类就没有这两个按钮了，如Surface Properties and System Data windows Dialog boxes with OK buttons (including the dialog boxes for CODE V options such as MTF) do not commit anything to the back end until you click OK. If you click Cancel, no changes are actually made.对话框里的OK按钮点击后操作就生效了，点击取消那么你刚才的修改就不生效。 In the case of the Surface Properties and System Data windows (and a few others, all associated with the LDM), you can keep them open while you work in other windows, or close them by clicking the X in the upper right-hand corner of the window. 曲面性质窗口等其他窗口在操作其他窗口时可以打开也可以点击它右上角的X 关掉它。Changes made in these windows are committed immediately, just like the LDM spreadsheet; however, you can be sure data is committed to the lens database by clicking the Commit Changes button. You can see what data has been committed in the Command Window, which displays the commands generated for these operations.窗口中的数据像LDM中的一样也是马上生效的，但是它的修改指令是在点击Commit Changes后生效的，你可以在指令窗口中查看你的操作指令。
Don't worry too much about this—you can always use Undo to get back to any earlier state of the lens, in case you change something you did not intend. It's also a good idea to save your lens in a file whenever you make significant changes (File > Save Lens As menu).不必为此过于担心，你可以使用Undo回到镜头之前的任意一个状态以防止改变了你并不想改变的数据，在任何一个比较重要的改变之前存一下档也是个很好的主意。
Drawing Pictures

Now you can understand the LDM spreadsheet, but as they say, a picture is worth a thousand numbers. So it's a good idea to draw a picture of the lens as soon as you can. Many problems are easy to spot on a lens picture. There are a number of ways to draw lenses, including the very flexible VIEW option (Display > View Lens menu), but for now, there's a quicker way.现在你已理解LDM列表了，但是一幅图比一千个数字来得直观。所以能画图观察就画图观察，很多问题在图上都很容易体现。我们有很多种方法来绘图，包括Display > View Lens菜单，但现在我们有一种更便捷的方法。
•
Click the Quick 2D Labeled icon on the toolbar:

[image: image8.png]
It’s the middle one that shows a lens and a pencil along with the letter Q (for quick) and the letter L (for labeled—float the mouse over it to see the tool-tip help to see the message “Quick 2D – Labeled”).在中间你会看到一个透镜和铅笔图案的图标，它旁边有个字母Q和一个字母L（把鼠标放在图标上你会看工具提示信息“Quick 2D – Labeled”）Keep the resulting window open as you work (resize and move the window as desired). When you change something, click the “execute” button in the upper left corner of the window to redraw the lens picture.在你工作时一直开着效果窗口（把窗口调成你所需要的大小），但你做了某些修改后点击左上角的“execute”按钮来重绘镜头图像。
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Before analyzing this lens, you will more than likely need to scale it to the required effective focal length (EFL).在分析这个透镜前，你更可能需要将它缩放到所需的有效焦距。
Surface Operations: Scale the Lens

Although you set the f/number and field angles to the desired values in the New Lens Wizard, you need to be sure the lens has the specified effective focal length (EFL) of 6 mm. One way to determine this is to display a window of first order properties.尽管你在向导中设定了光圈数和视场角的期望值，你还是需要确定你的镜头的有效焦距是制定的6mm。确定这些的一个方法就是打开显示一阶性质的窗口。
1. Choose the Display > List Lens Data > First Order Data menu, and re-size/ re-position the resulting window for convenient viewing.

Note the value labeled EFL in this window (0.9528 mm). This is wrong for application, and scaling the lens data is the normal way to fix this.选择Display > List Lens Data > First Order Data菜单，并把它调整到合适的大小和位置上以方便查看，在这个窗口中你会看到EFL值是0.9528mm，这是不能应用的，缩放数据大小是校对它的常用方法。
Tip: You can place the EFL and various other lens properties on the status bar at the bottom of the main CODE V workspace. This allows continuous monitoring of these items. Choose the Tools > Customize menu and click on the Status Bar tab in the Customize dialog box to access this feature.你可以把EFL等其他各种镜头的性质放在CODEV工作平台下面的状态栏上去，这样你就可以随时监控这些项目了。选择Tools > Customize再点击Status Bar,你将在对话框中进入这些功能。
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2. Select surfaces 1 to Image in the LDM spreadsheet window (click in the surface # column and drag to Image to select the range).在LDM窗口中选中曲面1到像（点击surface #列并拖到像来选择它们）
3. Choose the Edit > Scale menu to display a dialog box (note that the surface range is set to 1 to Image).点击Edit > Scale菜单出现一个对话框（注意曲面范围是从1到像）
4. Click the button labeled Scale Effective Focal Length, then enter the value 6.0 in the field labeled Scale Value.点击Scale Effective Focal Length这个按钮，然后在Scale Value这个地方填入6.0
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5. Click OK to scale the lens.

[image: image12.png]
6. Click the recalculate button
in the List First Order Data window to update it.在List First Order Data窗口中点击重新计算来更新它。
Note that the EFL value is now 6 mm as desired. Note also that the paraxial image height is 2.99 mm (close enough to the desired 3 mm).你会发现EFL值变为我们所要的6mm，而且近轴像高也变为2.99mm（非常接近我们所要的3mm）
7. Click the Recalculate button in the Quick 2D Labeled Plot window to update the picture as shown below.在Quick 2D Labeled Plot窗口中重新计算，会更新得到以下图像。
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New Title and Starting “Save Lens” 
So far, so good, but before continuing, you should label and preserve the work you have done up to now. Noting that this is an expired patent which is about to be changed by optimization, you can set a new lens title and save this as a starting point.到目前为止，工作进展的相当好，但在进一步工作之前，我们需要标示和保存好我们现在的工作。将一个专利期已满的专利进一步修改优化并没什么大不了的，我们可以重新设定一个镜头名字并把它存为一个初模。
· Choose the Lens > System Data menu and click System Settings in the System Data window’s navigation tree.选择Lens > System Data菜单，并在系统数据导航树中点击System Settings
System Data is where most non-surface-related data can be viewed and modified. The basic System Data values (pupil, wavelengths, field) were defined in the New Lens Wizard, but you can view and change these properties and many others through the System Data dialog box.系统数据是大部分无相关镜头数据能查看和修改的。那些基本的系统数据（光瞳、波长、场）是在新镜头向导中定义的，但却能在系统数据对话框中查看和修改这些性质
· Select the Title field and change it to something like Dig. Cam. VGA: start (you have up to 80 characters, but don't include any quotes or apostrophes). Tab to or click in another field to commit this data to the CODE V lens database.选择Title处并把它改成类似Dig. Cam. VGA: start的名字（你可以填入80个字符但不能包括引号和撇号）。点击其他地方完成数据存入CODEV镜头基本数据。
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· Choose the File > Save Lens As menu and enter a file name such as DigCamStart.len, then click Save.选择File > Save Lens As菜单并另存为DigCamStart.len然后点击保存。
Analyze the Starting Point  
There are many types of analysis in CODE V, but only a few of them are needed to determine if you are meeting the specs. The results of these analyses will also guide the setup for optimization (if required):在CODE V里面有很多种方法来实现分析功能，但如果你使它们满足各种特性的话它们当中只有少数需要自己决定，这些分析结果会引导你进行一步步优化。
· First order requirements (done after scaling the lens, as detailed in “Surface Operations: Scale the Lens” on page 29; the scaled lens has the correct first​order focal length and image height)一阶性质的要求（你已完成了29页那些步骤）修改后的镜头满足我们所需的一阶焦距和像高这些要求
· Distortion (Field Curves and/or Distortion Grid)畸变（场曲率和畸变栅格）
· Sharpness (diffraction MTF—this will also establish depth of focus, by analyzing MTF with a different object distance)锐度（衍射MTF，这将通过在不同物距分析MTF来确定景深）
· Vignetting/illumination (Transmission Analysis)渐晕/强度（透过率分析）
In addition, you will also use a couple of quick analysis features for reference (spot diagram and ray aberration curves). 同时你将使用一些快速分析功能作为参考（斑点图和光线像差曲线）We will explain the basics of these analysis options now. Additional information will be provided in a later section of this guide that covers evaluation features. There is one more thing that needs to be done with the starting point, though it does not neatly fit into any specific analysis category: establish feasibility.我们现在就解释这些基本的分析选项，在下一章里关于评估功能的向导将给出更多的信息。现在还有一件关于初模的事要做，虽然它不跟任何性质的分析种类有关：确立可行性。
Assuming that someone will eventually manufacture this lens, there are certain practical issues. Are the elements too small or too large to make easily? Are they too thin or too thick for practical fabrication? 假定你设计的光学系统最终要由别人来加工制造，那就存在一个实际问题。单元是否太大或太小以至于加工困难？它们是否太薄或太厚了以至于难以制造？Can they be assembled and mounted easily? Is the glass available, and is it expensive? These are some basic questions, which must be answered on the basis of looking at the basic lens data and comparing it to some known experience (you may have to do some calculations and perhaps ask someone who has designed or built similar optics).它们是否装备方便？能不能得到这种玻璃，它们贵不贵？这些都是很基本的问题，在看基本数据并把它和经典案例对比时就需要得到解答（你要先计算一下加工和成本问题，也可以问一下有经验的人）
There are other feasibility issues that are more technically complex. One is tolerance analysis, which will be introduced later in this guide. 还有其他复杂的技术性的可行性问题，其中一个是公差分析，这点我们之后再来介绍。This relates to how accurately the elements must be fabricated and mounted to maintain a required level of performance. Another that won't be covered is thermal analysis (although CODE V can help with some aspects of this, such as changes in performance due to a simple temperature change).这将关系到这些部件实际上是如何制造和装备以使它能达到一个我们所需要的工作情况等级。另外一个不能被忽视的是热分析（虽然CODE V能进行这方面分析，但这只是基于简单的温度变化而进行演算的）
Quick Ray Aberration Curve

A ray aberration curve is a useful way of looking at ray trace data to see patterns that may cause problems. 光线像差曲线是一个查看光线追踪数据的非常有用的方法，它能从图中看出一些问题。Transverse ray aberrations are measured on the image surface as the distance from a particular ray to the chief ray for the same field point (for a perfect lens, this should be zero for every ray traced from the same field point). This is plotted as a function of position in the stop or pupil for a line of evenly spaced rays (a ray fan).横向光线像差是在像面上同一场点的一条特殊光线到主线的距离来测量的（对于理想镜头，同一场点发出的各种光线追踪的差应该是零）。它画出来就像一个一束均匀隔开的光线（一个光线扇形）在光圈或光瞳上的位置的函数
You are first looking for large deviations, including separations between the curves for different wavelengths (chromatic aberration). 你首先会看到曲线很大偏离，包括不同波长曲线间的偏离（色差）You may also look for distinctive patterns that represent coma, astigmatism, and other basic aberrations. 你也会看到其他像差的特征图像，如慧差、散光以及其他基本像差。Experience can tell you where such aberrations come from, suggesting where you might make corrections, perhaps in the form of additional elements or aspheres.经验能告诉你这些像差来自哪些因素，建议你在哪些地方修改，可能是新增元素构成。
The Quick Ray Aberration plot is a one-click version, which you run by clicking the Quick Ray Aberration plot toolbar button, shown below (for the general case, choose the Analysis > Diagnostics > Ray Aberration Curves menu, option name: RIM, for “rim ray”). 在工具栏中点击Quick Ray Aberration plot 就会得到快速像差图像（通常情况下选择Analysis > Diagnostics > Ray Aberration Curves菜单，选项名RIM意为rim ray）The Quick version is actually done by a macro and performs automatic scaling (it also supplies a text table of ray aberrations, generated by the ANA option). Note that the following graph is shown after zooming and positioning only the highest field angle in the Quick Ray Aberration Plot window.快速查看实际上是由宏完成的而且自动选择比列缩放（它同样提供一个由ANA生成的像差文字说明标签）。下面图像显示的是快速像差图中最大视场角部分像差图。
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The starting point doesn't show signs of any gross aberrations, though you can only tell this by looking at the scale and knowing what is big. The automatic scale value here is 0.023 mm, 23 microns. For comparison, the Airy disk diameter (diffraction spot size for a perfect lens) is 2.44*(wavelength)*(f/number), or about 0.004 mm

for f/3.5. This lens is not diffraction limited (nor would you expect it to be), but its aberrations are within a factor of 6 of the Airy size.初模不会告诉你像差的征兆，虽然你可以通过查看图像数据量程并知道它有多大。这幅图中，自动选择的量程为0.023mm。作为对比艾利斑的直径（对理想透镜的衍射斑）是2.44*波长*F值，或者对于3.5光圈数来说艾丽光斑是0.004mm，这个镜头不是衍射受限（我们也没期望它是），但是像差一般小于或等于艾利光斑大小的6倍。
Tip: Always use the graphical zoom tool to zoom in on the scale numbers for plots. Automatic scaling may make a lens look good, but the scale size may be large.通常使用图像范围工具来限定图像的量程范围，自动比例虽然能让图更协调更好看一些，但比例尺寸可能有点大。
Quick Spot Diagram  
A spot diagram is not a required part of the spec, but it is a quick and easy analysis that gives you a graphical picture of the imaging quality of the lens.点列图像并不是我们所要规格的部分，但它却是一种快速且简易的分析能给出你成像质量的图像。 Basically, many rays from each field point are traced through the system, forming a rectangular grid in the entrance pupil.很多发自不同场点的光线被系统追踪，在入瞳上形成一个方形的栅格。 A scatter plot of the rays' position is done on the image surface, one for each field, and usually color coded for wavelength, giving an idea of chromatic aberration. 这其中的一少部分到达像面上，这和波长有关，也就是色差的概念。The scale for plotting is determined automatically to fit the spots in the plotting area, so as with any analysis plot, you must check the scale size.绘制的比例将自动给出以便于符合点列绘制区域，因此，对于任何一个分析图谱你都要核查它的缩放比例。
To run this, click the Quick Spot Diagram button (general case: Analysis > Geometrical > Spot Diagram, option name SPOT). 为了运行它，可以点击Quick Spot Diagram 按钮（或用一般的流程Analysis > Geometrical > Spot Diagram,选项名为SPOT）For this lens, the spots for all fields are roughly the same size, though the shapes are different. The scale bar is 0.050 mm, 50 microns.对于这个镜头，所有场的斑点大小大致相等，尽管它们的形状不同。缩放条是0.050mm


Tip: The supplied macro spotdet.seq will plot spot diagrams with superimposed circles or rectangles representing a specified detector size or Airy disk. Choose the Tools > Macro Manager menu and locate the macro under Sample Macros/ Geometrical Analysis. Note that you will have to fill in the required data to run this macro.

Distortion
The paraxial image height is related to field angle by the relationship h = f tan è. If the real image height differs from this paraxial prediction, you have distortion. 近轴像高跟场角有关，它们的关系是h = f tan è.真实像高和近轴像高不同这就有了畸变。Distortion is therefore a field-related aberration, and it is often displayed as a plot along with another field-based aberration, astigmatism. These field curves are available by choosing the Analysis > Diagnostics > Field Curves menu, or by clicking the Quick Field Plot button on the toolbar.因此畸变是一种场致像差，并和其他场像差一起出现在图像里，场曲率可以通过Analysis > Diagnostics > Field Curves得到，或者点击在工具栏的快速场绘图按钮。
The resulting distortion curve has field angle as the vertical coordinate and percent distortion as the horizontal coordinate. It shows that the starting point is well within the specified 4% distortion for the lens. In fact, it's less than plus or minus 1% across the entire field of view.畸变曲线纵轴是场角，横轴是畸变百分比。从图中可以看出它非常好的符合指定的4%的镜头畸变。事实上，整个视场角里面它将少于正负1% Astigmatism (left side in plot window below) is well corrected at the full field, but there is substantial zonal residual at the intermediate fields.散光（左边那个曲线图）在整个场内非常好的符合，但是它们大部分停留在中间角度。
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A distortion grid is another way to view distortion that is perhaps a little more intuitive. In this case, you see a rectangular grid that represents the ideal (paraxial) image, with the distorted grid superimposed on it.畸变栅格是另一种很直观观察畸变的方法。既然这样，你可以看到一个矩形栅格代表着近轴像，伴随着畸变栅格叠加在它上面。 Since the field of view is defined by field angle for this lens, you need to convert the CCD horizontal (X) and vertical (Y) dimensions into field angle using h = f tan è again (we used the 3 mm corner distance to define the maximum field, but in this case we want to view the actual format of the field).既然对这个镜头来说，视场是又场角决定的，你需要把CCD水平方向和垂直方向的尺寸用h = f tan è转换成场角（我们用3mm角距离来定义最大场，既然这样我们就要看场的真实设计）From the spec, recall that the full detector dimensions are 3.55 x 4.74 mm. Divide these by twice the focal length and take the arctan to get the maximum Y and X field angles (16.48° and 21.55°).从特征性质可知整个接收器尺寸是3.55*4.74mm，除以两倍焦距并求反正切可得到Y和X的最大角为16.48° and 21.55°
1. Choose Analysis > Diagnostics > Distortion Grid menu.

2. Enter 21.55 in X FOV semi-field and 16.48 in Y FOV semi-field. Also choose Fiducial Marks Only for the reference grid, and click Execute.
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The distortion is small, so you need to zoom in on the plot to see it. Fiducial marks show the paraxial ray positions. This makes a less cluttered plot for small distor​tion cases.畸变很小，所以你需要选择放大某个区域来查看它，坐标点反映了近轴光线的位置，对很小的畸变情况来说它不是很容易区分。
MTF (“Sharpness”)  
With any type of camera, users are interested in qualities such as sharpness or resolution. Optical designers relate these qualities to MTF, or modulation transfer function. Modulation is essentially relative contrast, with 1.0 representing ideal contrast (perfect black and white, no degradation to intermediate grays). 对于任何一款相机，用户所关心的是它的成像质量如锐度或分辨率之类的。光学设计者用MTF（调制传递函数）来表征，调制实质上是相对对比，用1来表示理想的对比（纯黑和纯白，没有退化到中间的灰色）For large features (low spatial frequency), even a poor lens will have good contrast, while for higher frequencies (fine details), aberrations and diffraction blend the dark and light areas. If you determine and plot the MTF for the full range of spatial frequencies, for all field points, you can define the sharpness of a lens in very compact form.对于低频空间频率，甚至一个很糟糕的镜头也会有好的对比度，而对于高频空间频率（能很好的显示细节），像差和衍射会把暗的区域和亮的区域混在一起。如果你希望对整个区域每个场点定义和绘制MTF，你可以为镜头定义一个形式紧凑的锐度
1. Choose the Analysis > Diffraction > MTF menu.

Note that there is a Quick MTF button, but we want specific spatial frequencies, and the quick version doesn't support this. 选择Analysis > Diffraction > MTF菜单，注意到工具栏里有个快速MTF按钮，但我们想自己限定空间频率，而快速查看不支持
2. On the Frequency/Calculation tab, enter 68 for the Maximum frequency and 17 for the Increment in frequency.

Note that when you change a value on a tab, a red star (also called a change indicator), displays next to the tab title.在Analysis > Diffraction > MTF栏中输入68到最大频率，17到增加频率。你会发现当你修改了栏目中的数据时，在标题上会出现一个红星（也称为修改指示标）。
[image: image18.png]* Frequency/Cakcultion | Image Motion | % Graphis |

L Mainum fiequency  Ingiement i frequency
€ Difiaction [68.00000 17.00000
€ Geometical

7 Number o tags acoss dmetes [60




3. On the Graphics tab, enter 68 for the Maximum plot frequency and click OK.在Graphics中输入68到最大绘图频率，然后点击确定。
Recall that the CCD array has a maximum spatial frequency of about 67 lines/ mm, and the combination of 17 and 68 (4* 17) works well for this analysis.回顾我们的CCD阵列的最大空间频率是67 lines/ mm，而且17 and 68的组合对此分析很好
Tip: You can use the line-drawing and text tools on any graphics window to add information to help you read and interpret the plot. The added graphics will go away if you recalculate the plot, but you can choose the File > Save Window As menu if you want to save the annotated plot.你可以使用绘线或文字工具在任何图像窗口中添加信息来帮助你查看和注释图像，添加的信息将在你重新运算时失去，但是你可以选择File > Save Window As来保存你所要的注释图像
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It appears that the starting lens has very good MTF properties, meeting the low and high frequency sharpness requirements for all fields and azimuths (MTF can vary with direction, so two orthogonal directions are calculated, radial and tangential).从图中可以看出初模有很好的MTF特性，对于整个场和方位角无论是高频还是低频都满足锐度的要求（MTF会随方向而改变，所以正交坐标轴，切向的，弧矢向的都被计算出来）
The horizontal line at 0.25 MTF was added by hand using the line drawing tool. Note that we have not yet considered the depth of field issue, which requires that the lens meet the MTF spec with the object distance at 750 mm as well as the current “infinite” (1.0E10 mm) value. We will discuss this in Chapter 3, which covers optimization.在0.25MTF处用画线工具添加一条水平线，注意到我们还没有考虑景深问题，它要求镜头满足物距是750mm的MTF特性就像现在无限远情况一样（1.0E10 mm），我们将在第三章讨论它，它包含优化问题。
Vignetting/Illumination 
The spec requires at least 60% relative illumination at the corner of the field (full field in your system data). This is to include vignetting effects (clipping of off-axis rays due to apertures on surfaces other than the aperture stop surface) as well as angular effects (“cosine fourth” is a well-known approximation to relative illumination vs. angle). 特性要求在场的角落至少要有60%的相对强度（在你的系统数据里也就是满场情况）。这包括渐晕效应（由于一部分光线被孔径光阑截止了）和角效应（余弦因子是个很好的关于强度和角度的近似关系）The program will model the relationship between pupil size (or f/number), surface apertures, and so-called vignetting factors.程序将设置光瞳尺寸（光圈数），光圈，渐晕因子的关系。
The system used for this is very flexible but a bit complex and will be explained in more detail in Chapter 10. The short version is this. Vignetting factors determine the reference rays, which in turn determine default apertures. 这样系统就可变通了但却也复杂了，我们将在第十章更详细介绍。在这里简单说，渐隐因子决定了参考光线，而它又依次决定默认孔径。These in turn determine the rays that get through in calculations such as MTF and many others. For design purposes, you can directly change the vignetting factors, to expand or contract the cone of light from off-axis fields, and the default apertures are adjusted accordingly.它们通过计算MTF和其他来依次确定光线。处于设计目的，你可以直接改变渐晕因子来扩大或缩小非轴上光线的发射圆锥体，同时默认孔径也就做出了相应调整。 In this patent, the upper and lower Y vignetting factors for the full field are 0.21 and 0.11, respectively. What relative illumination does this produce?在这个专利里面，Y上下方向在满场时的渐晕因子是0.21和0.11
There are at least two ways to look at this, and one is already done.我们有两种方法得知它，其中一种我们已做过了。
• Click the Text tab of the MTF output window you created in the last section. Scroll down to the output table for the last field. (0.0, 26.5 degrees).点击上节做好的MTF输出窗口的文字栏。翻动页面到最下面(0.0, 26.5 degrees)那个地方。
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Note that in addition to the tabular MTF data, there is additional information for each field point. Relative illumination is especially helpful in this case, and it is 58.8%, just a little below the required 60% in the spec (note that the value for cos**4 of 26.5° is 0.64).注意到除了表格式的MTF数据外，还有其他很多场点的额外信息。相对强度在这里格外有用，从中可以看出它是58.8%，稍低于我们所要求的60%（26.5°余弦值的4次方） You could play with the vignetting factors (found on theFields/Vignetting page of the System Data window) to try to improve this, but since this is close to the spec, you can leave the vignetting alone for now, and see if it improves during optimization.你也可以考虑渐晕因子来改善（在System Data 窗口中找到Fields/Vignetting），但既然这里很接近我们所要的特性，我们就可以不管渐晕了直到优化时再来查看它。
The other place to see illumination data is in the Transmission Analysis option (Analysis > System menu), which will provide more detailed illumination data, including the effects of coatings, if any. For this option, CODE V will assume a quarter-wave anti-reflection coating on each glass surface, unless you delete this coating or apply a user-defined coating.另外一个能够看到强度数据的地方是Transmission Analysis在Analysis > System菜单里，那儿会提供更加详细的强度数据。在CODEV里面假定所有玻璃表面都发生半波损失，除非删除涂层或用户自己另外设定涂层。
Establish Feasibility  
This lens looks pretty good as it is, considering that you simply picked an old patent based on some requirements, then scaled it. Are you done? Consider the size and thickness of the elements. Although it is possible to fabricate and mount very small lens elements, these elements are awfully thin for their size.这个镜头看上去非常好了，考虑到你只是简单地按所需要求选择了一个专利作为初模，并对它加以修改。就这样完成了吗？考虑下每个单元的尺寸和厚度，虽然制造并装备这些非常小的镜头元件是有可能的，但这些元件对它们的尺寸来说是非常薄的。
The original patent had a focal length of about 1 mm, though it was probably scaled to unit focal length for patent purposes (it may have been a much larger lens, perhaps for 35 mm film, for which it would have a focal length of about 43 mm for this field of view).原专利的焦距是1mm，但是它有可能为一个专利目的修改为单位焦距（它是一个大得多的镜头，也许有35mm的胶片，对于这个视场它需要43mm的焦距） At EFL=6 mm, the middle (negative) element is 1.5 mm in diameter and only 0.126 mm thick -- just 126 microns (at 43 mm, this element is a more reasonable 0.9 mm thick). Just to give you a visual impression, here is a plot of this lens at approximately real scale:有效焦距为6mm，中间那个透镜（凹透镜）的直径是1.5mm，而且只有0.126mm厚—只有126微米（在43mm时，它才更合理有0.9mm）。这里有一幅近似真实比例的图正好能让你有个直观的映像。
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For optics of this size to be handled and worked, you will need to require reasonable center and edge thickness values, perhaps 0.9 mm for the center and 0.8 mm for the edge thickness values. This means that as good as this design appears to be, you are not done yet. You will need to use constrained optimization (the Automatic Design or AUTO option) to reconfigure the lens to meet all the requirements.当光学性质满足后你需要规定一个合理的中心和边沿的厚度，或许中间厚0.9mm，边沿厚0.8mm是不错的选择。这意味着你的设计看上去很好了，但这还不够。你需要做一些限制性的优化来设置镜头使它满足各种要求。
There is at least one additional issue of practicality, which is glass selection. All three fictitious glasses in the patent are all high index glasses (1.786, 1.717, 1.835). High or low index (e.g., >1.65 or <1.45) glasses are generally less common and thus more expensive than mid-range index glasses. 这里至少有一件额外的关于实践的事情还要做，那就是我们玻璃的选择。我们所有的三块虚拟玻璃都是高折射率玻璃（1.786, 1.717, 1.835）。过高或过低的折射率(e.g., >1.65 or <1.45)的玻璃都是不常用的或是很昂贵的。You can use the glassfit.seq macro to quickly convert these glasses to the closest real equivalents (choose the Tools > Macro Manager menu, then run glassfit.seq, found under Sample Macros/Material Information in the Macro dialog box). This macro runs interactively in the Command Window (question/answer format). Using Schott glass and allowing automatic replacement, you get the following:你可以使用glassfit.seq宏来快速把这些玻璃转换成最接近的真实玻璃（选择Tools > Macro Manager菜单，运行glassfit.seq，能在下拉菜单Sample Macros/Material Information中找到它），在指令窗口中以交互方式运行（问答形式）。使用Schott玻璃，并选择自动替换，你会得到如下图表（上面那副图表）：
Note that only SF1 is a “preferred” (common) glass, while NLASF41 is an “inquiry” glass (special order). LAFN28 is listed as US $315 per pound ($693/kg), which is about 19 times the price of BK7, the most common optical glass. 看到SF1是一种普通玻璃而NLASF41却是需要特别订做的玻璃，LAFN28要$693/kg ，是BK7这种普通玻璃价格的19倍。These are not the best choices for a low-cost digital camera, even if the elements are very small (note that you could use the COST option to find the weight and estimated glass cost; choose the Analysis > Fabrication Support >Cost Analysis menu). It certainly would make sense to try to constrain the glass choice to a lower-index and cheaper region of the glass map. This can be done in AUTO.这对于低成本来说不是个好的选择，尽管每个单元都很小（你可以通过CODEV成本分析功能在Analysis > Fabrication Support >Cost Analysis中算出重量和花费）
Conclusions

To summarize, in this chapter you have:总结一下，在这章里面我们学会了：
· Interpreted a spec for a digital camera lens design说明数码镜头设计的性质
· Used the New Lens Wizard to locate a suitable starting point from a database of expired patents使用新镜头向导通过一个专利的基本数据来确定一个合适的初模。
· Scaled the lens for the application修改镜头来适应我们的用途
· Analyzed the starting point and determined some guidelines for optimization分析初模并确定优化方针
If you haven't saved your work, you should do so now, so it is available for use in subsequent chapters of this guide. Choose the File > Save Lens As menu and give the lens file a name such as DigCamStart.len. In the next chapter, you will use this starting point to optimize a lens that has acceptable optical performance as well as reasonable fabrication possibilities.如果你还没有保存好你的工作，那么现在赶紧保存。在下一章，我们将在这个初模的基础上来优化它，使它既满足光学性质又能方便制造加工。

Chapter 3

Make It Better:

Optimization

In this chapter, you will learn how to optimize the digital camera lens that you set up in the last chapter. This will include setting up variables, determining and defining constraints, and analyzing the results of the optimization. Some advanced optimization features will also be discussed, including Global Synthesis.在这一章我们将学习如何优化上一章所做的数码相机镜头。这包括设置变量，确定约束条件，分析优化结果。一些高级的优化功能将会讨论，包括Global Synthesis
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About Optimization

Purpose

The purpose of optimization is to generate the best possible optical system that can be achieved within a given set of physical and other constraints. The term “best” is measured by an error function which combines image error data into a single number that we then attempt to make as small as possible.优化的目的就是制作一个满足各种物理或其他限制要求的最有可能的光学系统，所谓的最佳是由误差函数衡量的，它把像差数据转换成一个数字，我们期望这个数字越小越好。 CODE V's error function is pre-defined in its basic structure, although a variety of controls and weights are available that allow you to modify it easily and extensively. It is even possible to replace this error function with a completely user-defined error function, although this is somewhat more difficult and is seldom actually necessary.CODEV的误差函数是预先设定好的，但是它的控制变量和权重是可变的，你能够容易地并广泛地修改它，它甚至可以用你自己定义的更复杂的误差函数来替换，尽管这会更难一些而且也没有多大实际必要。
Methods

CODE V's optimization feature is called Automatic Design, AUTO for short. AUTO uses an accelerated damped least squares (DLS) algorithm to generate changes in variables that improve the system. Constraints place boundaries on the search for optimum solutions.CODEV的优化功能也成为自动设计，简称AUTO，它用最小二乘法修改变量来改善系统，限定把边界条件加在最优解的寻找上。 AUTO uses Lagrangian multipliers to impose constraints only when needed. This allows exact constraint control while not requiring constraints to be included in the error function itself, usually resulting in faster, smoother convergence to an optimum solution within the constrained solution region.在必要的时候AUTO会用Lagrangian乘数加入限定条件，在误差函数本身不需要包含限定时允许准确的限定控制会使我们更快的得到结果，在约束收敛范围内得到一个优化解。
Defaults

The default values built into AUTO allow you to use AUTO with little or no attention to the details of error function construction and with minimal input requests. At the same time, the many optional controls, weights, constraints, etc., allow you great flexibility when needed for unusual designs or fine tuning in later design stages.在AUTO内设的默认值能让你无需关注误差函数的细节并且很少需要输入各种要求。同时，可选的控制、权重、限定等功能能让你在非一般情况设计和在后面的微调时灵活处理
The AUTO process

Though you can achieve results from AUTO by treating it as a black box, you may be interested in the outlines of the internal procedures. The diagram below shows the general flow of the design process, including the parts that AUTO handles. The meaning of the various steps will become clearer as we set up and run an example problem.虽然你可以把AUTO当作一个黑匣子来获得所要的结果，但你会对它内部流程的轮廓感兴趣。下面的简图能让你了解它设计过程的大致流程，包括AUTO处理这一部分。当我们开始处理一个实例问题时，各个步骤的意义将变得更清晰。
Chapter 17 of the CODE V Reference Manual describes the Automatic Design option in detail; the section titled “Discussion of Input and Computations” (page 17-58) is especially valuable for understanding how AUTO works.17章的CODE V Reference Manual对自动设计选项描述的比较详细，名为“Discussion of Input and Computations”的部分对理解AUTO是怎样工作的特别有用。
Automatic Design Process
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Local vs. Global
If you think of the error function as a space of multi-dimensional hills and valleys, the goal is to find the lowest possible valley. In local optimization, you will find the valley nearest your starting point. 如果你把误差函数当作一个多维的山谷，那么你的任务就是找到最可能低的山谷。在局部优化时，我们将在初模附近找到这个山谷。Global optimization will locate valleys farther from the starting point in its search for the deepest valley, or global optimum. CODE V's Global Synthesis® (GS) is an extremely good global optimizer that can find multiple solutions from virtually any starting point.全局优化时能让你在寻找最低山谷或最优解时找到离初模更远的地方去。CODEV的全局综合功能是一个非常好的全局优化器，能让你从任何初模找到很多解。
The Game Plan

It may seem that there are a lot of steps in this chapter, but there are really just a few, plus a lot of explanatory text. To help you see the forest as well as the trees, here is an outline of the game plan for optimizing this lens. These steps will all be done in the Automatic Design option dialog box (Optimization menu), except for defining variables, which is done in the LDM, and the analysis checks, which will be done in the MTF and FIELD options:这一章貌似有很多操作步骤，但事实上只是多加了一点说明性的文字而已，为了让你就像看到树一样能看到森林，这里有一个优化这个镜头的游戏方案的轮廓。这些步骤将在自动设计选项的对话框(Optimization menu)中完成，除了定义一些变量，这已经在LDM中完成了，和在MTF和FIELD选项中的分析核查。
· Define as variables all radii of curvatures, thickness values, and fictitious glasses, then save this revised starting point.定义好所有的曲率半径，厚度，虚拟玻璃，并把修改后的初模保存。
· Make sure all glass elements are thick enough (General Constraints tab).确保所有的玻璃元件都足够的厚度。（一般性限定）
· Make sure the glass index doesn't get too high (General Constraints tab).确保玻璃折射率不是太高了（一般性限定）
· Constrain the effective focal length (EFL) to the current 6 mm value (Specific Constraints tab).限定有效焦距为当前的6mm这个值（特殊限定）
· Draw the lens on each optimization cycle (Output Controls tab).每次优化完后都把镜头画绘制出来（输出控制）
· Use the default spot size (transverse ray aberration) error function, but trace more rays in the grid (Error Function Definitions and Controls tab).用默认的斑点误差分析，但是在栅格图里追踪更多的光线（误差函数说明和控制）
· Analyze the lens by re-running earlier evaluations (one click updates on windows from the last chapter, mainly the VIEW, MTF, and FIELD options).通过重新运行之前的评价来分析（在VIEW,MTF,FIELD等窗口中点击更新）
· Modify AUTO settings to refine the solution (Error Function Weights tab).修改AUTO设置来完善解 Now on to the details!

Variables

Defining Variables

You need to tell CODE V which lens parameters are free to vary when it tries to optimize your lens. These variables are defined in the LDM and are stored with the lens data when you save the lens in a file. 在你优化一个镜头时你需要告诉CODEV哪些镜头参数是可变的，这些变量是在LDM中定义的并随着镜头数据一起被保存。Deciding what to vary is not always a simple task, but in centered systems, it is typical to vary all glass surface curvatures (but not the image surface curvature, since you usually want a flat film or detector surface), all air spaces, and the thickness values of positive glass elements (to allow the program to keep good lens edges without restricting curvatures too much).确定哪些量是可变的并不是一件容易的工作，但是在共轴系统中经典的做法是设置所有的玻璃面的曲率为变量（但不是像面，既然你通常想要一个平坦的胶片或接受面），所有的空气间隔和玻璃元件的厚度也被设为可变量（程序能保持镜头边沿有个合适的厚度而不用受曲率的过多限制） Glass is often varied also (index and dispersion). This requires using a special variable “fictitious glass” form in CODE V, since catalog glasses have fixed properties and thus cannot be directly varied.玻璃也经常被设为变量（折射率和色散），这需要用到CODEV里面的一个特殊变量“fictitious glass”,既然玻璃目录里的性质是固定的不容易直接修改的。
Use the LDM

Variables are defined in the LDM. By default, everything is frozen initially. To vary a radius or thickness, place the cursor on it in the Lens Data Manager window, right-click, and choose Vary from the shortcut menu. A small v appears next to the parameter, indicating that it is a variable. 变量是在LDM中定义的，在默认情况下，所有数据都是固定不变的，为了改变半径和厚度，把光标放在镜头数据管理窗口上右击它，在弹出的快捷菜单中点击Vary ，一个小V出现在参数后面，表示它是可变量。If you vary something by mistake, right​click on the parameter and choose Freeze from the shortcut menu to remove the v. You can also select multiple values of one or more types and change all the selected values to variables with a single right-click Vary.如果你某些地方修改错了，右击参数并在弹出的快捷菜单中选择Freeze可以除去小V。你也可以一次选中多个变量右击设置为可变量。
If it is not already open, you will need to open or create the 6 mm f/3.5 digital camera lens starting point from last chapter.如果你还没有打开文件，那么马上打开或做一个6mm焦距，光圈数为3.5上一章中的数码相机镜头初模
1. Choose the File > Open menu, locate the digital camera lens file you created in the last chapter (DigCamStart.len or whatever you called it), and click OK.

If you save and later open a lens from the File menu, any analysis windows that were open at the time of the save will be restored when the lens file is opened.选择File > Open菜单，找到你上一章所做的数码相机镜头的文件，点击确定。如果你是先保存了一个镜头再打开这个文件，那么你保存的镜头里的那些分析窗口也会在你打开文件时保留下来。 Note that this does not happen if you open the lens from the Command Window with the RES (restore) command. In this case, the lens is restored without changing other windows.注意到如果你是用指令窗口里的RES命令打开镜头的话这些情况将不会发生，在这种情况下在不改变其他窗口的情况下保存下文件。
2. In the LDM spreadsheet window, drag to select the Y Radius of curvature values for surfaces 1 through 6.在LDM表格中选中表面1~6的Y Radius
3. Right-click on one of the selected cells and choose Vary as shown below.像下面那样在其中一个单元格右击并选中Vary
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4. Repeat this procedure for the thickness values (select and vary thickness for surface 1 to surface 5 as a range, then select the image surface thickness and vary it separately; do not include surface 6, as this will remove the PIM solve from this surface).在厚度值中重复此操作（选中曲面1~5为变量，然后选中像面厚度格外设定变量，不要包括曲面6，这样会消除近轴像的求解值）
The LDM spreadsheet window with all variables is shown on page 50, following the discussion of fictitious glass.所有变量都设置好了的LDM在50页可以看到，下面我们将讨论虚拟玻璃。
Fictitious Glass

Varying glass involves additional considerations and possible extra steps, since both the index and dispersion properties of a glass can vary. To be used as a variable in AUTO, a material must be defined as a fictitious glass. If a catalog glass is selected as a variable, it is automatically converted to its equivalent fictitious glass (in a final design, the optimized fictitious glasses need to be replaced with their nearest real equivalents by the user, often with the help of the supplied macro).改变玻璃需要额外的考虑和步骤，既然玻璃的折射率和色散性质都能修改。为了能在AUTO中设为变量，材料必须定义为虚拟玻璃。如果玻璃库里的玻璃被选为可变量，那么它将自动的转换成等价的虚拟玻璃（在最终设计里面，用户要把被优化的虚拟玻璃用最接近的真实玻璃来替换，通过glassfit.seq宏的帮助来完成） Fictitious glasses have a special form. For a glass of refractive index (at 587.6 nm, or “d” light) of 1.620 and an Abbe value (i.e., reciprocal dispersion), or V-value of 60.3, the fictitious glass name is 620.603 (the period tells the program this is a fictitious glass). An alternate form, 1.620:60.3, is also accepted by CODE V, and allows the entry of glasses with n > 2.0 and v > 100.虚拟玻璃有个特殊的形式。对于一个折射率为1.62（587.6nm波长），Abbe value为60.3（色散的倒数）的虚拟玻璃名字为620.603（句号告诉程序这是虚拟玻璃），另一个名字是1.620:60.3，它同样能被codev所接受，并且允许输入n > 2.0 and v > 100。
In the case of the digital camera lens, the patent that it is based on already includes fictitious glasses, although they are frozen. You should also note that all three glasses have very high index of refraction values (1.7 to 1.8), which generally indicates an expensive glass. You will need to vary glass but constrain its index in AUTO (this will be done in the next section).在数码相机镜头这个例子中，专利已经用了虚拟玻璃了，但它是固定的，而且你会发现三个透镜的玻璃都是很高的折射率的，这意味这些玻璃很贵。这就需要修改玻璃并对它的折射率在AUTO中进行限定（这将在下一部分完成）
1. To vary the glass for surface 1, right click on the glass name in the LDM window and choose Vary from the shortcut menu.为了改变曲面1的玻璃，右击LDM窗口中的玻璃名字并在快捷菜单中选择Vary
The v will display next to the glass name, indicating that it is a variable. For a polychromatic (multi-wavelength) system, we normally vary both index and dispersion, and this is the default. But there are other possibilities for glass.在玻璃名字的旁边将显示一个小v表示它是可变量，对于多色光系统我们通常同时改变折射率和色散，而且这是默认的，但对于玻璃还有其他可能情况。
2. Left-click on the v for the glass on surface 1 (or right-click and choose Couple).左击面1上的小v（或右击并选中Couple）
This displays the Coupling Editor dialog box. Coupling is one way to link together variables, but in the case of variable glass, it also gives access to the index and dispersion variables.这里展示的耦合编辑对话框是一种把变量连接在一起的方法，但是对玻璃变量来说它也可以访问折射率和色散变量。
3. Double-click the Index and Dispersion cell for surface 1双击面1的Index and Dispersion
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You can vary the index and dispersion separately or together. Since this is a polychromatic lens, varying both Index and Dispersion is OK. Dispersion Boundaries are the boundaries of the glass map polygon which limits the range of allowed glass types. This will be discussed in the next section under General Constraints.你可以单独或一起改变折射率和色散，既然这是一个多色光镜头，需要同时改变折射率和色散。色散边界是玻璃图多边形的边界它限制了允许玻璃的范围，我们将在下一部分的一般性约束中来讨论它
4. Click Cancel.点击取消
5. Right-click and choose Vary from the shortcut menu for the glass for surfaces 3 and 5.对曲面3和5右击并选中Vary
When you are through, the LDM window should look like this:当你完成以上操作时，LDM窗口应该像下面一样：
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6. Choose the File > Save Lens menu to save a new version of the lens file with the variable definitions.选择File > Save Lens来保存新的镜头文件版本，它是做了变量定义的。
Automatic Design Settings

Now you are ready to launch Automatic Design and define some settings that will guide the optimization of this lens.现在你要准备开始自动设计并确定好设置，它能指导你如何优化这个镜头。
• Choose the Optimization > Automatic Design menu to open the Automatic Design (AUTO) dialog box.选择Optimization > Automatic Design菜单并打开Automatic Design对话框
Note: Do not click the OK button in the Automatic Design dialog box until you reach the end of this section.注意在你完成了这部分的所有工作前不要点击自动设计对话框里的确定键。
You will be changing settings on several tabs before you click OK to run AUTO. If you click OK by mistake, don’t panic: choose the Edit > Undo menu to get the starting lens back and click the Settings button in the AUTO output window to resume.在点击确定运行AUTO之前你将要修改好几个选项页的设置。如果你不小心点了确定，不要慌：选择Edit > Undo菜单来回到你的初始镜头，然后点击AUTO输出窗口中的Settings来重新开始。
AUTO is a very powerful feature with many categories of settings divided among ten tabs in the input dialog box.AUTO是个非常强大的功能，由很多设置项目分布在输入对话框的十个页面。
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Most of the settings determine parameters such as weights, or flags for special behaviors, such as drawing the lens on each optimization cycle. Two categories of settings define boundary conditions or constraints.这里面的大部分设置决定了很多参数如权重，特殊行为的标志，每次优化后镜头的图。有两项设置是用来定义边界条件或限定的。
The first of these boundary condition categories is called General Constraints. These are general boundary conditions that control thickness values and glass map boundaries to help protect you from unrealistic designs. Thickness constraints prevent such problems as negative edge thickness, or lens elements that overlap. Glass boundaries keep the program from choosing physically unrealistic index and dispersion values. 这些边界条件的第一类叫一般性限定。这是一般性边界条件，它控制中心厚度值和玻璃图边界以避免不实际的设计。厚度控制能保证你不会出现负的边沿厚度或元件交叠在一起的问题。玻璃边界能让程序不会选择那些没有实际物理意义的折射率或色散值。General constraints are always in place, applying limits for all surfaces in all zoom positions. You can set the values for these limits, and override selected general constraints with specific constraints on a per-surface basis.一般性限定总是应用在所有表面的限制，你可以设置这些限制值，不用理睬原来选定的一般性限定而对每个表面进行独立设置。
The second boundary condition category is called Specific Constraints. Specific constraints are applied only when entered by the user. Many constraints are surface based, referring to a physical or optical property. Other constraints apply to the whole system or to a range of surfaces. Specific constraints allow you to define your requirements in great detail, though you must be careful not to over-constrain the system, since this can limit the improvement potential.第二类边界条件是特殊限定。特殊限定只允许用户设置，很多限定要考虑表面的物理或光学性质，其他限定适用于整个系统或一部分表面。特殊限定能让你更细致的定义你的要求，但你要小心别限定过头了，这样会限制你改善的潜在可能。
General Constraints

General Thickness Constraints

For this small lens, you must be sure that the elements are thick enough to be handled and worked easily. According to fabrication specialists, the values suggested here are reasonable, though it's possible to go as thin as 0.5 mm for elements of this size. 对这个小镜头，你必须保证它足够厚能够加工和处理。按照制造专家的意见，这里推荐的值是合理的，虽然它有可能每个元件只有0.5mm厚。This is best handled by the general thickness constraints. In addition, we noted in the last section that the glasses in this patent are all high-index glasses. Glass map boundary constraints can be used to limit the optimized glasses to a lower index, lower cost region of the glass map. Assuming you have already opened the AUTO dialog box (as described on page 51):通过一般性厚度限定处理是最好的，另外，我们前面的章节看到这个专利的玻璃是高折射率的玻璃。玻璃图边界限定能把优化玻璃限制到低折射率，低造价范围的玻璃图。假定你已打开自动设计对话框。
1. Click the General Constraints tab.
1. Enter 1.4 in the Maximum Center Thickness field.

2. Enter 0.9 in the Minimum Center Thickness field.

3. Enter 0.8 in the Minimum Edge Thickness field.

Glass Map Constraints

The glass map used in AUTO is a plot of Nd vs. (NF - NC). The picture below is an excerpt from the map in Chapter 17 (Automatic Design) of the online CODE V Reference Manual. It shows the default, four-sided glass map boundary, a region that allows fairly high index values. 在AUTO用到的玻璃图是Nd vs. (NF - NC)，下面的图是摘自17章的CODE V Reference Manual 。它显示了默认的四个边界的玻璃图，一个允许合适高的折射率的范围。Note that the Schott designations for some of the specific glasses are indicated as labeled points, and the default glass boundaries are constructed to enclose the region that contains the most commonly available glass. It's important to note, however, that AUTO can only vary glass on a continuous basis—it does not locate discrete real glasses. You must convert a fictitious glass to a real glass after optimization in order to analyze final performance and make fabrication possible (e.g., with the glassfit.seq macro).注意到Schott给一些特殊玻璃做了标记，默认玻璃边界建成了，它包含了很多常用玻璃的范围。AUTO只能连续地修改玻璃，它不能找到不联系的真实玻璃。你必须在优化之后把虚拟玻璃转换成真实的玻璃，以便你能分析最后的表现和制造可能性。（用glassfit.seq宏）
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The glass map constraint polygon can actually have 3 to 5 sides, labeled A through E (it must be a convex polygon; see the Reference Manual for more details). It appears that SF2 defines a convenient point for a three-sided glass region that keeps the maximum index below 1.65 (the hope is that this will result in cheaper glasses after optimization). Note that the glass map boundary changes will apply to all surfaces by default, though you can define a separate glass map for each surface if necessary.玻璃图限定多边形实际上有3~5条边，用A~E标记出来（它必须是凸多边形，Reference Manual有更详细的说明），可以看出SF2定义的一个三角形的点，使之包含了折射率最大值低于1.65的范围。（我们期望优化后能找到个更便宜的玻璃）
1. On the General Constraints tab in the AUTO dialog box, click on the glass SF4 in the cell Map4 of the Glass Map Boundary spreadsheet at the bottom of the dialog box and press the Delete key (or CTRL-X) to remove the fourth boundary.在AUTO对话框里General Constraints分页里点击对话栏下面的玻璃图边界表Map4单元格里的SF4玻璃，然后删除它来除去第四边界。
2. Click in the cell Map3 and type SF2 to define the new corner point for the triangle region.然后点击Map3单元格并输入SF2来定义三角形区域的新角点。
Your General Constraints tab should look like this:
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Specific Constraints

There are many things you can constrain when needed to define the boundary conditions of the optimization. These include many physical and optical properties (overall length, focal length, distortion, real ray properties, paraxial ray properties, etc.). Constraints can be entered in several ways, including equality (hold to a value), upper and/or lower bounds, and minimize (don't directly constrain, but minimize difference from target value).在定义优化的边界条件时有很多东西需要限定，它们包括很多物理的和光学的性质（总长度，焦距，畸变，真实光线性质，近轴光线性质等）。限定可以通过很多方法输入，包括等号（等于某个值），大于或小于号，最小化（不直接限定，但根据目标值最小化） You can also designate constraints as display only (these are calculated and displayed on each cycle but not controlled in any way). Constraints and constraint modes are discussed in detail in Chapter 17, “Automatic Design,” of the online Reference Manual你可以指定限定是显示（在每次优化循环时被计算并显示出来，但不做任何控制），限定及限定模型将在第17章在线Reference Manua的自动设计做更详细的讨论。
In most lenses, at least one specific constraint is required to hold the scale of the system. This could be a paraxial or real ray height at the image surface, a paraxial slope, or a real-ray direction cosine value. But most often, it is the paraxial effective focal length of the system (EFL), which you will use here.在大多数镜头里面至少有一样特殊限定是要设置它的系统的比例的，这可以是像面上近轴的或真实的光线高度，近轴光线的斜率或真实光线的方向余弦值。但是在大多数情况下，你所要用的是系统的近轴有效焦距
1. In the Automatic Design dialog box, click the Specific Constraints tab. The table starts out empty (no specific constraints are defined by default).在自动设计对话框中点击特殊限定分页，一个以空白页开始的分页（在默认情况下没有任何特殊限定）
2. Click the Insert Specific Constraint button, which is near the bottom of the dialog box.点击对话框底部的Insert Specific Constraint按钮
The Edit Constraint dialog box is displayed, with Effective Focal Length as the default constraint (since this is the most common case). You could actually just click OK in this case, but first note that you can choose from several categories from the list at the top left, and that for each category, there is a separate list of constraints at the top right. Effective Focal Length is the first of the Optical Definitions. Edit Constraint对话框将显示出来，在有效焦距里是默认限定（在大多数通常情况下），在这个例子中你可以点击确定，但首先请先看一下，你能够在左上角的列表里选择很多种类，在对应的右上角有不同的限定列表，有效焦距是光学定义里的第一项。
3. Click in the Constraint Target field and enter 10.0 (note that this is the WRONG value; however, this is just a demonstration, since 6 is the value you want).点击Constraint Target并输入10.0（注意这是个错误的值，但这只是为了证明6才是你所需要的值）
4. Click the Calculate Default Target button.点击下面的计算默认目标按钮。
Note that the value of 6 is back. This button evaluates the current value of the constraint as a convenience. You don't have to keep it, but it's correct for this case.你会发现6又回来了，这个按钮在评价当前限定值是个很方便的途径，但是你这会不需要保存它。
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5. Click OK to enter this constraint.点击确定
Tip: When entering a constraint, be sure to click in a data field after choosing the constraint, to allow the program to display the data required by the constraint type. If it is a surface-based or field-based constraint, be sure to select the desired surface or field (and zoom position if it is a zoomed system). The Calculate Default Target button will show the current value to help you determine a good target.在输入完一个限定时，请确定在数据区域点一下，这样能让程序显示你输入的数据。如果这是一个基于表面或基于场的限定，请确定你选的是你所要限定的那个面和区域。就算默认值按钮会显示出当前值来帮你决定一个好的目标。
Other Specific Constraints

In many cases, other specific constraints will be necessary, but you won't usually know this until you make a trial optimization run. It is usually best to limit the number of specific constraints to those that are really important to the design. For this lens, you have a distortion specification of less than 4%. 在很多情况下，其他特殊限定是必要的，但是在你试运行优化之前你是不知道要做哪些限定的。那些对设计比较重要的最好是限制它的特别限定数目。You could easily add this (it's in the Optical Definitions category in the Edit Constraint dialog box, and is labeled Distortion Fraction Y; the command is DIY). If you did add it, you would select the field at which you will control it (typically the last or largest field), and you would seldom control it at more than one field. The starting point of this lens has very low distortion, so you would probably start out without constraining it (in the Edit Constraint dialog box, you could add it in Display Only constraint mode to monitor it). If distortion becomes a problem, you can add it (possibly twice, to limit plus and minus distortion). 对于这个镜头，畸变说明要求小于4%,你可以很容易地添加它（它在Edit Constraint 对话框的Optical Definitions类，并标记为Distortion Fraction Y，它的指令是DIY），如果你已添加了它，你可以选择你要控制的场（通常是最后一个或最大的一个），而且你只能控制一个。这个初模有非常低的畸变，所以你开始时可以不用限定它（在Edit Constraint对话框里，你可以添加它到Display Only模式来监视它），如果畸变成为问题了，你还能添加它（可能是两次，去限制正负畸变）。
Image clearance (“back focus”) is another common constraint, although a digital camera requires no space for a reflex mirror or prism, as do some film cameras. In digital cameras, the scene is viewed either through a separate viewfinder or on the LCD preview panel. Other common constraints come from the Manufacturing and Packaging category, such as Overall Length.后焦可能是另一个常用的限定，然而数码相机并不像胶卷相机那样需要空间来安装反射镜或棱镜。数码相机的景象不是在一个独立的取景器里就是在LCD上。其他常用的限定在Manufacturing and Packaging类别里，如总长度。
“Constraints: Problems and Solutions” on page 73 describes common problems and their corresponding constraint approaches.73页的“约束:问题和解决方法”会描述常见问题和相应的限定方法
Output Controls

For lenses with many surfaces, you might wish to restrict the amount of surface​based output that appears. You might also wish to see a table of variables. In this case, you can accept the defaults for these things, but it will be helpful to see a picture of the lens on each optimization cycle. You are still modifying the AUTO settings (almost done!).一个镜头有很多面，你可能希望限制基于表面输出的显示数目，你也许还希望看到一张变量表。在这里你可以接受默认设置，但是看一下各个优化循环的图是很有帮助的。你将继续修改AUTO设置。
1. In the Automatic Design dialog box, click the Output Controls tab.在自动设计对话框里点击输出控制分页。
2. Check the box labeled Draw system at each cycle.在Draw system at each cycle栏目上标上勾
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This will result in a separate tab in the AUTO output window for each cycle, labeled with the error function.这会在每一次优化循环后AUTO输出窗口有一个标为误差函数的独立分页。
Error Function Definitions and Controls

The Error Function Definitions and Controls tab is the one that by default appears first in the Automatic Design dialog box. This is where you set the general approach and some control values (e.g., error function type, Global Synthesis). You can accept the default error function type (transverse ray aberration, essentially RMS spot size), but for this particular lens, you should change to a different ray grid interval value.误差函数定义和控制分页在自动设计对话框里第一次是默认出现的，在这里设置一般方法和一些控制值（误差函数类型，全局综合）。你可以接受默认的误差函数类型（横向像差，本质上就是RMS点列图大小）
1. In the Automatic Design dialog box, click the Error Function Definitions and Controls tab.在自动设计对话框里，点击误差函数定义和控制分页。
2. Enter 0.22 as the Ray interval in the Ray Grid Controls section.在Ray Grid Controls部分的Ray interval里面输入0.22
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Save Your Settings (Option Set) and Run AUTO

The settings in the Automatic Design dialog box will persist in your CODE V session for as long as you keep the associated AUTO window open, allowing you to modify the settings and re-run AUTO multiple times. But to use the settings in a future CODE V session, you need to save them. This is easy enough to do and often saves a lot of later work.在自动设计对话框里的设置将一直保存在OCDEV里面只要你一直开着AUTO窗口，让你能修改设置并多次运行AUTO。但为了今后还能使用它，你需要把他们保存起来，这做起来非常简单，而且为以后省了很多工作。
1. Click the Option Set button in the lower left corner of the Automatic Design dialog box.点击自动设计对话框左下角的Option Set按钮。
2. Click the Save As button点击另存为
3. Type a name for the saved set of AUTO settings and click OK.输入名字确定
4. Click the Close button in the Option Sets dialog box.在可选设置对话框里点击关闭。
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5. Click OK in the Automatic Design dialog box.在自动设计对话框里点击确定
This will create the AUTO tabbed output window and run AUTO with the settings you entered. It will typically run for several cycles, stopping when it can no longer make much improvement in the lens (there are settings on the Exit Controls tab in the AUTO dialog box for determining when to stop).这将创建一个AUTO输出窗口并按照你输入的设置运行AUTO。它一般将运行好几个循环直到它不再能继续提高镜头的性能了（在AUTO对话框的Exit Controls分页里有个设置能决定什么时候停止）
Understanding AUTO Output

When you click the OK button, AUTO starts to run, displaying a tabbed output window (TOW) and a control dialog with a stop button. The TOW always includes a Text tab which contains most of the output. If a per-cycle lens drawing is requested, you will also see multiple plot tabs, one for each cycle. You may also see an Error tab if there are any warnings or errors generated.当你点击确定后，AUTO开始运行并显示出多页输出窗口和一个带停止按钮的控制对话框，并在输出窗口里有一个文本分页它包含了大多数输出，如果需要每一次循环的镜头图像，你也可以查看到很多图像的分页，你也可能看到一个Error分页，如果有任何警告或错误生成。
The control dialog shows the current cycle number and error function value. Note that if you click the Stop toolbar button, AUTO may not stop immediately. It tries to complete the current cycle and make sure that the lens is valid before stopping.控制对话框显示出当前循环数和误差函数值，注意当你点击停止时，AUTO可能不会马上停止，它会尝试完成当前这个循环并确认当前这个镜头是有效的。
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The Error Function

The Error Function is the single most useful piece of information produced by AUTO as it runs. This single number represents the image quality of the lens, with zero representing an aberration-free lens. The default error function is made up of sums of squares of transverse ray aberrations in X and Y, scaled so that the value approximates the square of the RMS spot radius averaged across all fields and zoom positions.误差函数是在AUTO运行时生成的唯一最有用的信息，这个唯一的数字表征了这个镜头的成像质量，零意味着镜头没有像差。默认误差函数是有X和Y的横向像差的平方和，它的值近似于整个场和区域RMS点列图半径的平方。 Default error functions also exist for wave front error variance, fiber coupling efficiency, and MTF. The interpretation of the error function value is changed in these cases, but it is always defined such that smaller is better, and zero is ideal (but seldom achieved). A user-defined error function can also be used.默认误差函数同样存在波前差异。光纤耦合效率和MTF，误差函数值的解释在这几种情况下会改变，但通常情况下它定义的越小越好，零是一种理想状态（但几乎无法达到）。用户自己定义的误差函数也同样能应用。
To calculate the error function, CODE V traces a grid of rays in every defined wavelength from every defined field and zoom position. The grid is defined assuming that the entrance pupil has a unit (normalized) radius, and the spacing between rays is called the pupil fraction ray interval (command: DEL).为了计算误差函数，CODEV追踪每一个波长每一个定义了的场每一个位置的光线栅格。栅格定义为假定所有的入瞳都有归一化半径，光线间的分隔叫做光瞳部分光线间隔（指令为DEL） There is a macro (AUTOGRID.SEQ, found by choosing the Tools > Macro Manager menu, and is listed under Sample Macros/ Optimization) for looking at the ray pattern for specified DEL values. For the value of DEL chosen for this optimization, 0.22, the pattern is as shown in the figure below. (Note that you cannot run this or any macro while the AUTO dialog box or any other option dialog box is open.)这有个宏来查看指定的DEL值的光线图像（在Tools > Macro Manager菜单Sample Macros/ Optimization列表下面的AUTOGRID.SEQ），对于这个优化DEL值为0.22，图像如下面的插图所显示的那样（注意你不能运行这个宏或任何宏当你的AUTO对话框或其他可选对话框打开的时候）
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The transverse ray aberrations in X and Y are calculated on the image surface for each of these many rays, and the weighted sum of the squares of these aberrations determines the error function at each optimization cycle.这些X和Y方向的横向像差对每个光线在像面上计算出来，他们像差平方和的权重决定了每次优化循环时的误差函数。 The weights in this summation are important controls in optimization. Weights are defined for aperture position, wavelength, and field (X and Y components). For a more detailed treatment of the error function and other mathematical aspects of optimization, see page 17-89 (Technical Notes) in the online Reference Manual.这些和的权重在控制优化时非常重要，权重由孔径位置、波长和场（X和Y部分），关于误差函数更详细的处理和优化的其他数学方面内容可以参考Reference Manua17~89页
The AUTO Output Header

Take a look now at the text output from AUTO. The output starts with a section called the output header, which displays the inputs and defaults used in the calculation. These are labeled primarily in terms of commands.现在看一下AUTO的文本输出，输出开始于一个叫做输出顶部的部分，它显示输入和默认的计算，这些就指令而言是基本被标示的。
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The header starts by displaying the commands generated by your settings (EFL, DEL, etc.). It then lists potentially active specific constraints, in this case only EFL. “Potentially active” means that AUTO will dynamically determine if a constraint is needed at any given cycle, freeing as many variables as possible to control image errors. General constraints are listed next; the commands are not too hard to interpret (MNE is minimum edge thickness, MNT is minimum center thickness, etc.).它开始于显示设置所生成的指令（EFL,DEL等），然后列出可激活的具体限定，在这里只有EFL。“Potentially active”意味这AUTO运动地决定某个限定在每一次循环中是否需要，释放尽可能多的变量来控制像差。一般限定在之后列出，指令并不难被解释（MNE是最小边界厚度，MNT是最小中心厚度，等）
Tip: To see the commands for a category of inputs, click the tab of interest in the Automatic Design dialog box (e.g., General Constraints) and press the F 1 key. This displays the help page that describes the inputs, including their CODE V command names.为了查看输入种类的指令，点击自动设计对话框的你感兴趣的分页（例如一般限定）然后按F1键。这会弹出一个帮助页面描述输入，包括他们的CODEV指令名字。
Error Function Construction shows you the weights on the various components, as well as the DEL value used in the ray trace grid. Convergence Controls displays the exit conditions (MXC is maximum cycles, MNC is minimum cycles, TAR is error function target, and IMP is the target per-cycle fractional improvement). Output Controls includes only the lens drawing command in this case (DRA). This is followed by the number of variables, 18 in this case (6 radii, 6 thickness values, and 6 glass variables, the index and dispersion for each of 3 glasses).误差函数结构告诉你各个部分的权重，就像DEL值用在光线追踪栅格中一样。收敛控制显示推出条件（MXC是最大循环数，MNC是最小循环数，TAR是误差函数目标，IMP是每次优化循环微小改善的目标）。输出控制在这里只包含镜头绘图指令（DRA）。接下来列出来的是变量数，在这里有18个（6个半径值，6个厚度值，6个玻璃变量，3个玻璃的折射率和色散）。
Tip: You can get a list of the variables by clicking the Print Cycle Value button in the Variable Table area on the Output Controls tab of the AUTO dialog box.

Finally, the header text tells you that 18 constraints can be active, thanks to the 18 variables. This is an upper limit! In fact, you hope for a small number of active constraints so most “degrees of freedom” (i.e., variables) can be applied to improving the image quality.你可以点击AUTO对话框的输出控制分页的变量分页里的Print Cycle Value键来显示变量列表。文本会告诉你18项限定被激活，多谢了这18项变量，这是上限了。事实上你希望一个小的限定激活数目，这样被应用在提高成像质量上的“自由度”会更高。
AUTO Per-Cycle Output

A cycle in AUTO is roughly one iteration for which the error function and constraints are displayed. In fact, each cycle contains several mini-iterations, in which different parameters are tried and constraints added or dropped as needed, allowing maximum progress for the current configuration.一个AUTO循环是一个粗略的误差函数和限定的重复，事实上每一次循环有很多小重复，尝试不同的参数根据需要添加限定或放弃，是当前构造有最大程度上的提高。
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Note: The above output is for illustrative purposes only; your output may be slightly different.上图只是起个说明作用，你的输出可能会有点点不同。
Starting and ending each cycle is the error function value, labeled ERR. F. This is followed by its X and Y components from each field, allowing you to see which fields and components are contributing most to the error function, though the total error function value also includes weighting factors (e.g., a large X component at field 4 may not contribute much if the WTX F4 field weight value is small). 开始和结束每次循环是误差函数的值，它标记为ERR.F，它紧跟着每个场X和Y的部分，使你能够看到每个场和部分对误差函数的贡献，虽然误差函数的总值跟各部分的权重有关（例如，如果WTX4的权重值很小的话，那么在场4的X部分值也许很大但却对误差总值的贡献却不大）The surface data is listed next, followed by the basic first system properties (EFL, REDU or reduction ratio, PIM or paraxial image distance, OAL or overall length, EN/EX PUP or entrance/exit pupil distances).接下来列出的是曲面数据，紧跟着系统一阶属性（EFL,REDU或缩小率，PIM或近轴像距，OAL或总长，EN/EXPUP或入瞳/出瞳距离）
Finally there is a table of Active Constraints (10 on this particular cycle). EFL is listed first, with its target value, current value, and difference between these. Given that this is the only specific constraint, what are all the other constraints? They are general constraints that AUTO has determined will require control at this particular cycle. GL A S1 is a glass map boundary constraint (recall the glass polygonboundaries labeled A, B, C, in this case). Mn ET S1 is a minimum edge thickness constraint at surface 1.最后是一个激活限定列表(在这一特定的循环是10)，EFL首先列出，然后是目标值，当前值，他们之间的差。考虑到这只是一个特殊限定，那其他所有限定呢?他们是一般限定，AUTO会决定在这次特定的循环中是否需要控制。GL A S是玻璃图的边界限定（回顾玻璃多边形图里的A,B,C），MN ET S1是曲面1的最小边界厚度限定。
Constraint Costs

The program dynamically determines the constraints it needs to control at every cycle, based on their Lagrange multiplier values, which are listed in the cost column. Why is this called a “cost?” When a boundary condition is controlled, the program is restricted from going to a solution-space point (set of variable values) where the error function could get lower. This restriction from the optimum point “costs” you something in terms of the error function that can be achieved (if it could be released, the error function could be smaller).程序在运动地决定限定在每一次循环中是否需要控制，基于列在COST栏里Lagrange乘数值，为什么被称作“cost”呢？当一个边界条件被控制了，程序被限制了不能取这个求解区域的点，这个求解点却能是误差函数取最更小值。这种对适宜的点的约束代价是牺牲你的误差函数能取的值（如果约束放宽松点，误差函数将会更小）。Some constraints are harder to control than others, and these have larger magnitude costs. Although you can't directly compare costs for different types of constraints, larger values hurt more than smaller values, and if you see very large values (any positive exponent, e.g., 1E+02), this constraint is causing a big problem. You may need to remove it, or provide another variable that can allow it to be met more easily.有的限定比其他的更难控制，而且它们所牺牲的代价更大。虽然你无法直接比较不同限定的代价，但越大的值比越小的值损害大，如果你看到一个很大的值（任何正指数，如1E+02），这个限定将会导致一个很大的麻烦。你可能需要消除它，或想其他办法让它变得更简易The values and signs of the Lagrange multipliers are used along with other program data to determine which constraints to control on each cycle. The remaining variables (18 - 10, or 8 on this cycle) are available to try to improve the image quality.拉格朗日乘数的符号和值将用于程序的数据来决定在每次循环里由哪些限定来控制，剩余的变量是可用于尝试提高成像质量的。
Analyzing Results and Modifying Weights

If you have left open the analysis windows used when you defined the digital camera lens, it is a simple matter to update them to see the effects of optimization.如果你在用于定义数码相机时的分析窗口还打开着的话，那是一件很简单的事来看优化的效果。
1. Locate the MTF output window from your prior analysis.找到你MTF输出窗口
2. Drag the tab of the plot with the mouse to tear off a copy of the original MTF plot (this is optional but this method allows easy before/after comparison).从原来的MTF图中脱出一个复制的分页来(这是可选的，但是这种方法能便于比较)
3. Click the Execute (Recalculate) button in the MTF window to re-run the calculation and see the new MTF results.点击MTF窗口里的重新执行键来重新运算计算并可看到一个新的结果。
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This plot shows that the MTF is good for most fields and azimuths (T,R for tangential and radial, which correspond to Y and X), but a couple of the radial (X, dashed) component curves are low. You can relate this to the AUTO output as well. Click the Text tab of the AUTO output window and scroll to the bottom.图中可看出MTF在大部分场和方位角是好的（T和R是切向和径向，他们对应Y和X）,但是有一对径向曲线（X虚线）很低。你可以把它和AUTO输出结果做一下对比，点击AUTO输出窗口TEXT分页并滚到底部。
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Note that the largest error function components are the X values for F3 and F4, plus the Y component for F3. These correspond to the lowest MTF curves. Since the problem is related to particular fields and X components, you can modify the AUTO settings to increase the weight on some of these during optimization.看到误差函数最大的部分是X值的F3和F4还有Y部分的F3，这个影响到MTF的最低曲线。既然问题出在特定场和X部分，你可以修改AUTO设置来减小权重
1. Click the Modify Settings button of the AUTO output window.点击AUTO输出窗口的修改设置键。
2. Click the Error Function Weights tab in the AUTO dialog box. The default field weights come from the LDM data, which are all 1.0 as you can see in the Fields/Vignetting page of the System Data window (Lens > System Data menu). You can try to increase the X component weights for field F3 and F4, using 1.2, for example. 点击对话框里的误差函数权重分页。默认的场权重来自LDM数据，在系统数据窗口的场/渐晕页你可以看到所有的都是1.0（Lens > System Data menu），你可以尝试减小场F3和F4的X部分的权重，例如用1.2
3. Click in the first row of the spreadsheet labeled X-Aberration weights only, then double-click the first cell and choose field 3 (F3).点击X-Aberration weights only分栏，双击第一个单元格并选择F3
4. Enter 1.2 in the Value field for this row.在数值区输入1.2
5. Click the blank row and repeat the above procedure for field 4 (F4).点击空白行并在F4处重复上面操作
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6. Click OK to re-run AUTO with the new weights.点击确定并用新的权重重新运行
7. Click the Execute button in the MTF window to re-run the analysis.点击执行
Now the radial (dotted) curves are higher, but the T curve for F3 is even lower and will require more weight. You can quickly experiment with different field weights in X and Y, even lowering the weights for the axis (F1) and 0.4 (F2) fields, which have higher MTF than you need. Although you could switch to MTF optimization at this point, defining the targets for the MTF error function will probably take longer than interactively changing weights, re-running AUTO, and re-running MTF.现在径向曲线（点线）高多了，但是F3的T曲线还是很低需要更高的权重，你可以在X和Y设置不同权重来试验，甚至降低F1和F2的权重，将会得到比你想要的高的MTF。尽管你可以转换到MTF优化，但是定义MTF的目标值可能比重复改变权重并重新运行AUTO和MTF更花时间。As an aside, MTF is also convenient in another way, in that it reports both relative illumination and distortion for each field (in the Text output). This allows you to keep an eye on these specs as you tweak the MTF.在另一方面，MTF也是另一种很方便的方法，因为它能报告每个场的相对强度和畸变（在文本输出里面），这样能让你注意它的规格。
Final Optimization and Notes

After a few trials, you can find a set of weights (WTX and WTY) that will allow the lens to meet the MTF and other specs. One such set of weights is shown below (this was from the initial default-weight optimization shown in the previous section, using Undo each time to go back to the same starting point).经过几次尝试后，你会发现一组权重能让你的镜头满足MTF和其他规格，其中一组权重如下图所示（这来自前一章优化时开始默认的的权重，每次使用Undo能让你回到同样的开始起点）。
[image: image40.png]% and
Y-Aberation
weights

ZAberation
weights oy

Y-Aberation
weighls only

Fild | Zoom | Foous |
i 1 - 0b A1l zoom 1
B 2 < ob A1l Zoom 1
1] D
Fied | Zoom | Foous | Vaue |
i 3 - ob ALl Zoom 1 Tz —
z 4= 0 Al Zoom 1 13
1«
Fied | Zoom | Focus |
i 3 - o aul zoom 1





You may not get exactly the same solution, depending on the weights applied and the starting point, but your solution should have a similar performance. You should set a new title and save the lens file (by choosing the File > Save Lens As menu) when you get a good solution. The following figure shows the basic Quick 2D lens drawing, MTF, and LDM surface data of the final glass lens. 你或许不会得到同样的结果，这依赖于应用的权重和初模，但是你的解应该有类似的功能。当你获得一个好的解的时候你可以设定一个新的标题并存起来。下面的图是最终镜头的基于快速2D镜头绘图，MTF和LDM曲面数据图
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To get other final analysis results, click the Execute/Recalculate button on each analysis window used in earlier analysis (or run them again if you have closed them). For this solution, we get:为获得其他最终分析结果，点击重新执行键(如果你关闭了他们就再运行它们)，对这些解，我们得到：
· MTF meeting the spec at 17 and close to meeting the 51 lp/mm spec at 68 lp/ mm as well, giving some performance margin.MTF在17满足我们的规格，并在51 lp/mm很接近规格68 lp/ mm，留有一定余地。
· Distortion -1.7% at worst from Field Curves (Analysis > Diagnostics menu).在最坏的长曲率畸变是-1.7%
· Relative illumination 67.3% at full field (from MTF option). Transmission Analysis (Analysis > System menu, or TRA option) is more accurate and gives 63.2% for field F4, still above the 60% spec.满场时相对强度是67.3%，透过率分析更精确给出了F4时是63.2%，还是高于60%规格。
· The same TRA option reports average transmission of 88.2% at full field, although this is with the CODE V default of a single layer anti-reflection coating (1/4 wave MgF2) on each surface, which was not specified. If all coatings are removed (Lens > Surface Properties menu, Cement/Coating page, click None for coating on each surface), the transmission drops to 66%. Some coating will probably be applied, but you should always check on details such as this in any lens specification.Actually, there is more to be done on this lens before it could be built.同样的TRA报告在满场时平均透过率为88.2%，虽然这是CODEV默认在表面有单层减反射膜。如果所有的减反射膜都除去（Lens > Surface Properties menu, Cement/Coating page, click None），透过率会降到66%.有些膜会被应用，但是你需要核查每个镜头规格的细节。事实上还有很多事要干在这个镜头制作之前。
What About Real Glass?

One key point is to change the fictitious glass to real glass as discussed at the end of Chapter 2. This would typically be followed by some minor re-optimization, since the real glass will not precisely match the fictitious glass. The supplied macro glassfit.seq is very useful, but you should not always use the “fit all glasses automatically” option.在第二章末讨论的将虚拟玻璃转化成真实玻璃是一个很关键的问题。这通常还要有些小的再优化，既然真实玻璃不精确匹配虚拟玻璃，宏glassfit.seq是非常有用的，但是你不能总是用“自动调配所有玻璃”选项。 In this lens, the automatic-fit Schott glass for the front and rear elements (620.603) was NSK16, which was listed as an inquiry (category 2) glass. SK16 gave just as good a solution but was listed as a preferred (readily available and cheaper) glass. This may reflect some interim conditions with Schott, and of course you also have other manufacturers available as well.在这个镜头，于这个镜头来说，用SCHOTT玻璃库自动替代的结果是第一个面和最后一个面的材料（620.603）是NSK16，它列为一种可查询的玻璃。SK16有一个很好的解但是它是列为首选玻璃（真实可得到的并更便宜），这反映了一些过度条件，或者你可以使用其他制造商的可获得的玻璃也一样。
The point is that you can run the glassfit macro in several modes, including one where the five closest glasses are listed for each surface. This allows you to choose a glass based on other properties in addition to a good match in index and dispersion.这里的关键点是您可以运行GLASSFIT几种模式，包括为每个表面列出五种最接近的材料。这能让你基于除了匹配折射率和色散外的其他性质来选择玻璃。
What About Depth of Focus?

One spec we did not cover is depth of field for this fixed-focus lens. It should have the specified MTF for object distances from 750 mm (2.5 feet) to infinity, but we have only designed and analyzed at infinity. To evaluate this:还有一项我们还没有涉及到的规格是这个定焦镜头的景深，它需要特定的MTF物距从无限远到750mm，但是你只是在无限远处设计和分析，为了评价这点：
1. In the LDM spreadsheet window, right-click on the thickness of surface 6 (the cell containing this data is shaded gray) and choose Delete Solve from the shortcut menu.This removes the PIM solve so the lens will not be re-focused when the object distance is changed. 在LDM窗口，右击曲面6的厚度（包含这个数据的单元格是灰色的）并选择Delete Solve，这会除去PIM解，所以镜头在物距改变时不再会调焦了。
2. Change the object thickness from infinity to 750 mm.选择物的厚度为从无限远到750mm。
3. Re-run MTF and any other desired analysis.重新运行MTF和其他需要的分析。
You can see that the spec is not met at the close focus distance with this solution. There are several ways to deal with this, using through-focus parameters in AUTO, or by using Zoom to optimize the close and far distances simultaneously. We won't do this here, but note that with the extra margin of MTF at the high frequencies (51-68 lp/mm), a compromise focus solution is feasible.你可以看到对于这个解而言接近焦距的地方不满足规格，我们有好几种方法来处理它，在AUTO中使用through-focus参数，或者同时使用Zoom来优化近距离和远距离。我们在这里并不做，但是要注意在高频区域保留一个额外的MTF余地，一个折中的焦距解是合理的。
Plastics, Private Catalog, and Aspheres

Would a low-cost digital camera lens really be built from an all-glass triplet? This depends on a lot of factors, but plastic or a glass/plastic hybrid solution is certainly worth considering. Plastic lenses are molded, and a mold can include aspheres just as easily as spheres. Plastic is cheap, and molding offers cheap large volume fabrication with many options. But plastics do have several problems:是不是一个廉价的数码相机镜头一定全都是由玻璃制成的吗？这依赖于很多因素，但是一个塑料的或是玻璃塑料混合材料也是值得考虑的。塑料镜头是用模具制造的，模型就仅仅简单的是个球形，塑料还很便宜，有很多可选的便宜的大容量制作。但是塑料有很问题：
· There are fewer optical plastics than there are optical glasses, with a smaller range of index and dispersion values, and their properties are not as standardized.光学塑料并不像光学玻璃那样多，只有很小的折射率和色散区域，而且他们的性质不能规格化。
· Plastic molding may require looser fabrication tolerances than glass.相对于玻璃塑料成型需要更宽松的装备公差
· Most optical plastics are more sensitive to temperature changes than are optical glasses.大多数光学塑料比光学玻璃对稳定变化更敏感。
Plastics are not supplied in standard catalogs like Schott, Ohara, Hoya, and other glasses. They must be defined with the lens using the Private Catalog feature (PRV command) before they can be used in a lens definition. ORA supplies a macro that defines many common optical plastics, based on various sources.塑料并不像Schott, Ohara, Hoya一样提供在规格的种类里，在他们能用在镜头定义之前你必须用Private Catalog feature (PRV command)来定义镜头。ORA提供一个宏能基于各种各样的资源上定义很多常见光学塑料。
1. Choose the Tools > Macro Manager menu and locate the macro prvpl.seq under Sample Macros / Material Information. Click the Run button. When the macro dialog box displays, click OK to run the macro.选择Tools > Macro Manager菜单找到prvpl.seq,他在Sample Macros / Material Information下面，点击运行，当宏对话框弹出是点击确定并运行宏。
This will define the various materials with names such as 'P-CARBO' (polycarbonate) and 'P-STYRO' (polystyrene).这将用P-CARBO之类的名字来定义各种各样的材料。
2. To use a PRV material, type its name in quotes in the Glass field in the LDM spreadsheet. The quotes can be single or double but are required and case is considered (i.e,. the material 'P-CARBO' is not the same as 'p-carbo'). 为了使用PRV材料，在LDM里的玻璃处在引号里填入它的名字，引号可以是双引号也可以是单引号但是必须要。
3. To review the names and types of PRV materials, choose the Review > Private Catalog menu.要回顾名字并输入PRV材料，选择Review > Private Catalog菜单
You cannot view or modify the properties here, you can only see what is defined and delete unneeded materials.在这里你不可以查看和修改它的性质，你只能够定义和删除你不要的材料
4. To view the properties of defined PRV materials, choose the Display > List Lens Data > Private Catalog menu.为了查看定义了的PRV材料的性质，选择Display > List Lens Data > Private Catalog菜单
For more information on the Private Catalog feature, see Chapter 5 in the online

Reference Manual.更多的关于Private Catalog的信息请查看第五章里的Reference Manual
Global Synthesis and Other AUTO Features

At the start of this chapter we mentioned the difference between local and global optimization. Up to now, we have used local optimization, which efficiently locates the nearest local minimum from the starting point, subject to constraints. CODE V also has a very powerful global optimizer which is called Global Synthesis® (GS) and is easily available whenever you are using AUTO.在这一章的开始我们先说一下局部优化和全局优化的差异，到目前为止我们使用了局部优化，它高效地从初模找到了最接近的局部最小值，服从限定。CODEV同样有一个非常强大的全局优化功能，它叫做全局综合，而且它在你使用AUTO的任何时候都能很容易地使用它
1. Save your lens in an easily located file name (e.g., GS1DCAM.LEN).GS will save each solution in a lens file (GS1DCAM1, GS1DCAM2, etc.), and a distinct name will make it easier to keep track of the many files.保存你的镜头在一个容易找到的文件名里(e.g., GS1DCAM.LEN)，GS将会把所有解存到这个镜头文件中，一个易区分的名字能让你更容易从大量的文件中找到它。
2. Click the Settings button in the AUTO window you are working with to access the AUTO dialog box.点击AUTO对话框的设置键
3. On the Error Function Definitions and Controls tab, click the button labeled Global Synthesis Yes.在Error Function Definitions and Controls分页里点击Global Synthesis Yes
4. Click OK.点击确定
That's it! Your regular AUTO run is now a global run, and the program will generate multiple solutions. You may choose to limit the solutions with a Maximum Error function target value (on the Exit Controls tab) to filter out poor solutions. You may also find it necessary to add some constraints such as overall length (OAL), since the design forms can very a great deal. Use of the DRAW feature (Output Controls tab) is also advised. You will usually get a wide variety of solutions (as in this case), some better than the starting point, but these should be reviewed for quality and to see if they are suitable for manufacture.那么你正常地运行AUTO是运行一个全局优化，程序会生成很多解。你将选择用最大误差函数值目标来过滤一些糟糕的解来限制解（在Exit Controls分页中），你还会发现增加一些如总长之类的限定是有必要的，既然设计形式可以是大量的。使用DRAW功能也是被推荐的(Output Controls tab),你通常将获得很广的各种各样的解(在这种情况下)，不少比初模要好，但他们还需要再看一下他们的质量并确认他们是否适合加工。AUTO has many other features including optimization of MTF, fiber coupling efficiency, and even user defined error functions. The online Reference Manual is the best place to start to learn about these features.AUTO还有其他很多功能包括MTF优化，光纤耦合率，甚至是用户自己定义的误差函数, Reference Manual是学习这些功能的好地方。
Constraints: Problems and Solutions

This is a table that lists various problems and the solutions in terms of what you would constrain, with menu instructions and a command example for each. This does not include the complete instructions for handling the problem, but is meant to guide you on where to look. Keep in mind these points:下面这张表列出了你将可能遇到的问题和解决方法，以每个菜单说明书和指令为例。这不包括处理这些问题的完整的说明，但能指导你去哪里查找解决的方法。记住下面这几点：
· Too many constraints can limit finding a good solution.太多的限定会限制寻找一个好的解
· Be sure you have variables that can affect the things you are constraining.请确定你设置了变量，他们能影响你要限定的东西。
· If equality or bounding (< or >) constraints cause problems, you can use the Minimize mode to push the constraint toward a goal value rather than holding it exactly.如果等号或大于小于号限定导致了问题，相比于让它准确不变不如用最小化方式来推动限定到目标值
The online Reference Manual has more details on constraints and their use. Reference Manual有更详细地介绍限定和他们的使用。
	Problem
	Specific Constraint Tab

(AUTO dialog box)
	Command Example

	Lens or section of lens is

too long透镜或镜头的部分太长
	Manufacturing &

Packaging, Overall Length

(surface range)制造或包装，总长（曲面区域）
	OAL S3..9 < 21.5

	Need a paraxial pupil at a

specific location (dummy

or real surface)需要一个近轴光瞳在指定的位置（仿制的或真实的曲面）
	Paraxial Ray Trace Data,

YZ Paraxial Chief Height

(surface, set target to zero)近轴光线追踪数据，YZ近轴主要高度（曲面，设置目标值为零）
	HCY S 13 = 0

	Need intermediate image

at a specific location

(dummy or real surface)在某个特定位置需要中间像（仿制的或真实的曲面）
	Paraxial Ray Trace Data,

YZ Paraxial Marginal

Height (surface, set target

to zero)近轴光线追踪数据，YZ近轴边沿高度（曲面，设置目标值为零）
	HMY S15 = 0

	Distortion is too big畸变太大
	Optical Definitions,

Distortion Fraction Y

(field number, usually

bounded, enter twice if

two bounds are needed)光学定义，Y畸变（场数，通常限定，如果两边都要限定就输入两次）
	DIY F3 < 0.025

DIY F3 > -0.025

(note: 2.5%)

	A particular element

(surface) is too big in

Diameter某一元件直径过大
	Manufacturing &

Packaging, Max Semi

Diameter (surface number)制造和包装，最大半径(曲面数)
	SD s9 < 25.5



	Problem
	Specific Constraint Tab

(AUTO dialog box)
	Command Example

	I want f-theta linearity我想要f-theta线性
	Real Ray Trace Data,

Local Y Surface

Coordinate (image

surface, ray 1, field

number, calculated f-theta

target value)真实光线追踪数据，局部Y面坐标（像面，光线1场数，f-theta计算值）
	Y Si R1 F3 = -127.8

	General thicknessconstraints are OK exceptfor one very small element一般厚度限定很好但除了一个很小的元件
	Manufacturing &Packaging, Edge thickness(surface, value)制造和包装，边沿厚度（曲面，值）
	ET s10 < 2.1

(overrides MNE, etc.)

	I can't find a constraint that does what I want to do我找不到我要设定的限定
	User Defined Constraints

allow you to define many

conditions using macros

and program data. See

User Constraints tab and

Help for more details.用户自定义限定允许你通过宏和程序定义很多条件，更多详细说明见用户自定义分页和帮助
	See online Help and/or

Reference Manual.
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Resolution分辨率


Pixel size 像素大小Sensitive area感光区域


Objective Lens物镜


Focus焦点


Focal length焦距


Geometric Distortion f/number几何畸变 F值


Sharpness锐度
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